CVE-2016-0760

Published on: 08/19/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:13 PM UTC

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Certain versions of Sentry from Apache contain the following vulnerability:

Multiple incomplete blacklist vulnerabilities in Apache Sentry before 1.7.0 allow remote authenticated users to execute arbitrary code via the (1) reflect, (2) reflect2, or (3) java_method Hive builtin functions.

  • CVE-2016-0760 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 8.8 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW LOW NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.5 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Apache Hive CVE-2016-0760 Multiple Remote Code Execution Vulnerabilities Third Party Advisory
VDB Entry
cve.report (archive)
text/html
URL Logo BID 92328
CVE-2016-0760: Hive builtin functions “reflect”, “reflect2”, and “java_method” are not blocked in Apache Sentry Mailing List
Vendor Advisory
mail-archives.apache.org
text/xml
URL Logo MLIST [sentry-dev] 20160804 CVE-2016-0760: Hive builtin functions "reflect", "reflect2", and "java_method" are not blocked in Apache Sentry

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationApacheSentry1.5.1AllAllAll
ApplicationApacheSentry1.6.0AllAllAll
ApplicationApacheSentry1.5.1AllAllAll
ApplicationApacheSentry1.6.0AllAllAll
  • cpe:2.3:a:apache:sentry:1.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:sentry:1.6.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:sentry:1.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:sentry:1.6.0:*:*:*:*:*:*:*: