CVE-2016-1569

Published on: 01/13/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:04 PM UTC

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Certain versions of Firebird from Firebirdsql contain the following vulnerability:

FireBird 2.5.5 allows remote authenticated users to cause a denial of service (daemon crash) by using service manager to invoke the gbak utility with an invalid parameter.

  • CVE-2016-1569 has been assigned by [email protected] to track the vulnerability - currently rated as MEDIUM severity.

CVSS3 Score: 6.5 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW LOW NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED NONE NONE HIGH

CVSS2 Score: 4 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE NONE PARTIAL

CVE References

Description Tags Link
oss-security - Re: CVE Request: FireBird RDBMS: authenticated clients crash FireBird when running gbak with invalid parameter Exploit
www.openwall.com
text/html
URL Logo MLIST [oss-security] 20160110 Re: CVE Request: FireBird RDBMS: authenticated clients crash FireBird when running gbak with invalid parameter
Firebird / Code / Commit [r62783] sourceforge.net
text/html
URL Logo CONFIRM sourceforge.net/p/firebird/code/62783/
[SECURITY] Fedora 23 Update: firebird-2.5.5.26952.0-1.fc23 lists.fedoraproject.org
text/html
URL Logo FEDORA FEDORA-2016-bec6b9c395
oss-security - CVE Request: FireBird RDBMS: authenticated clients crash FireBird when running gbak with invalid parameter www.openwall.com
text/html
URL Logo MLIST [oss-security] 20160110 CVE Request: FireBird RDBMS: authenticated clients crash FireBird when running gbak with invalid parameter
[#CORE-5068] gbak with invalid parameter crashes FB - Firebird RDBMS Issue Tracker tracker.firebirdsql.org
text/html
URL Logo CONFIRM tracker.firebirdsql.org/browse/CORE-5068

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationFirebirdsqlFirebird2.5.5AllAllAll
ApplicationFirebirdsqlFirebird2.5.5AllAllAll
  • cpe:2.3:a:firebirdsql:firebird:2.5.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:firebirdsql:firebird:2.5.5:*:*:*:*:*:*:*: