CVE-2016-1966

Published on: 03/13/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:05 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Certain versions of Firefox from Mozilla contain the following vulnerability:

The nsNPObjWrapper::GetNewOrUsed function in dom/plugins/base/nsJSNPRuntime.cpp in Mozilla Firefox before 45.0 and Firefox ESR 38.x before 38.7 allows remote attackers to execute arbitrary code or cause a denial of service (invalid pointer dereference and memory corruption) via a crafted NPAPI plugin.

  • CVE-2016-1966 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 8.8 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE REQUIRED
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.8 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
USN-2917-3: Firefox regressions | Ubuntu www.ubuntu.com
text/html
URL Logo UBUNTU USN-2917-3
[security-announce] SUSE-SU-2016:0909-1: important: Security update for lists.opensuse.org
text/html
URL Logo SUSE SUSE-SU-2016:0909
Debian -- Security Information -- DSA-3520-1 icedove www.debian.org
Depreciated Link
text/html
URL Logo DEBIAN DSA-3520
USN-2934-1: Thunderbird vulnerabilities | Ubuntu www.ubuntu.com
text/html
URL Logo UBUNTU USN-2934-1
USN-2917-1: Firefox vulnerabilities | Ubuntu www.ubuntu.com
text/html
URL Logo UBUNTU USN-2917-1
Debian -- Security Information -- DSA-3510-1 iceweasel www.debian.org
Depreciated Link
text/html
URL Logo DEBIAN DSA-3510
Mozilla Products: Multiple vulnerabilities (GLSA 201605-06) — Gentoo security security.gentoo.org
text/html
URL Logo GENTOO GLSA-201605-06
[security-announce] openSUSE-SU-2016:0733-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:0733
[security-announce] SUSE-SU-2016:0820-1: important: Security update for lists.opensuse.org
text/html
URL Logo SUSE SUSE-SU-2016:0820
Mozilla Firefox Multiple Flaws Let Remote Users Execute Arbitrary Code, Spoof the Address Bar, Overwrite Files, and Deny Service - SecurityTracker www.securitytracker.com
text/html
URL Logo SECTRACK 1035215
[security-announce] openSUSE-SU-2016:0894-1: important: Security update Third Party Advisory
lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:0894
Access Denied Issue Tracking
bugzilla.mozilla.org
text/html
URL Logo CONFIRM bugzilla.mozilla.org/show_bug.cgi?id=1246054
mozilla-release: changeset 312975:f0d2911a9a4e hg.mozilla.org
text/xml
URL Logo CONFIRM hg.mozilla.org/releases/mozilla-release/rev/f0d2911a9a4e
[security-announce] openSUSE-SU-2016:0731-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:0731
Memory corruption with malicious NPAPI plugin — Mozilla Vendor Advisory
www.mozilla.org
text/html
URL Logo CONFIRM www.mozilla.org/security/announce/2016/mfsa2016-31.html
[security-announce] SUSE-SU-2016:0777-1: important: Security update for lists.opensuse.org
text/html
URL Logo SUSE SUSE-SU-2016:0777
Oracle Linux Bulletin - January 2016 Third Party Advisory
www.oracle.com
text/html
URL Logo CONFIRM www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
[security-announce] openSUSE-SU-2016:0876-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:0876
USN-2917-2: Firefox regressions | Ubuntu www.ubuntu.com
text/html
URL Logo UBUNTU USN-2917-2
[security-announce] SUSE-SU-2016:0727-1: important: Security update for lists.opensuse.org
text/html
URL Logo SUSE SUSE-SU-2016:0727

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationMozillaFirefoxAllAllAllAll
ApplicationMozillaFirefox Esr38.0AllAllAll
ApplicationMozillaFirefox Esr38.0.1AllAllAll
ApplicationMozillaFirefox Esr38.0.5AllAllAll
ApplicationMozillaFirefox Esr38.1.0AllAllAll
ApplicationMozillaFirefox Esr38.1.1AllAllAll
ApplicationMozillaFirefox Esr38.2.0AllAllAll
ApplicationMozillaFirefox Esr38.2.1AllAllAll
ApplicationMozillaFirefox Esr38.3.0AllAllAll
ApplicationMozillaFirefox Esr38.4.0AllAllAll
ApplicationMozillaFirefox Esr38.5.0AllAllAll
ApplicationMozillaFirefox Esr38.5.1AllAllAll
ApplicationMozillaFirefox Esr38.6.0AllAllAll
ApplicationMozillaFirefox Esr38.6.1AllAllAll
ApplicationMozillaFirefox Esr38.0AllAllAll
ApplicationMozillaFirefox Esr38.0.1AllAllAll
ApplicationMozillaFirefox Esr38.0.5AllAllAll
ApplicationMozillaFirefox Esr38.1.0AllAllAll
ApplicationMozillaFirefox Esr38.1.1AllAllAll
ApplicationMozillaFirefox Esr38.2.0AllAllAll
ApplicationMozillaFirefox Esr38.2.1AllAllAll
ApplicationMozillaFirefox Esr38.3.0AllAllAll
ApplicationMozillaFirefox Esr38.4.0AllAllAll
ApplicationMozillaFirefox Esr38.5.0AllAllAll
ApplicationMozillaFirefox Esr38.5.1AllAllAll
ApplicationMozillaFirefox Esr38.6.0AllAllAll
ApplicationMozillaFirefox Esr38.6.1AllAllAll
ApplicationMozillaThunderbirdAllAllAllAll
Operating
System
OpensuseOpensuse13.1AllAllAll
Operating
System
OpensuseOpensuse13.1AllAllAll
Operating
System
OracleLinux5.0AllAllAll
Operating
System
OracleLinux6AllAllAll
Operating
System
OracleLinux7AllAllAll
Operating
System
OracleLinux5.0AllAllAll
Operating
System
OracleLinux6AllAllAll
Operating
System
OracleLinux7AllAllAll
  • cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.0.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.1.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.2.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.2.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.3.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.4.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.5.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.6.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.6.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.0.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.1.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.2.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.2.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.3.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.4.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.5.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.6.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:38.6.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:*:
  • cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*:
  • cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*:
  • cpe:2.3:o:oracle:linux:5.0:*:*:*:*:*:*:*:
  • cpe:2.3:o:oracle:linux:6:*:*:*:*:*:*:*:
  • cpe:2.3:o:oracle:linux:7:*:*:*:*:*:*:*:
  • cpe:2.3:o:oracle:linux:5.0:*:*:*:*:*:*:*:
  • cpe:2.3:o:oracle:linux:6:*:*:*:*:*:*:*:
  • cpe:2.3:o:oracle:linux:7:*:*:*:*:*:*:*: