CVE-2016-2045

Published on: 02/19/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:15 PM UTC

CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Certain versions of Fedora from Fedoraproject contain the following vulnerability:

Cross-site scripting (XSS) vulnerability in the SQL editor in phpMyAdmin 4.5.x before 4.5.4 allows remote authenticated users to inject arbitrary web script or HTML via a SQL query that triggers JSON data in a response.

  • CVE-2016-2045 has been assigned by [email protected] to track the vulnerability - currently rated as MEDIUM severity.

CVSS3 Score: 5.4 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW LOW REQUIRED
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
CHANGED LOW LOW NONE

CVSS2 Score: 3.5 - LOW

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE PARTIAL NONE

CVE References

Description Tags Link
phpMyAdmin - Security - PMASA-2016-9 Patch
Vendor Advisory
www.phpmyadmin.net
text/html
URL Logo CONFIRM www.phpmyadmin.net/home_page/security/PMASA-2016-9.php
Set correct content type for JSON responses · phpmyadmin/[email protected] · GitHub Patch
github.com
text/html
URL Logo CONFIRM github.com/phpmyadmin/phpmyadmin/commit/0a24f92d081033576bfdd9d4bdec1a54501734c1
[SECURITY] Fedora 23 Update: phpMyAdmin-4.5.4.1-1.fc23 Third Party Advisory
lists.fedoraproject.org
text/html
URL Logo FEDORA FEDORA-2016-e55278763e
[SECURITY] Fedora 22 Update: phpMyAdmin-4.5.4-1.fc22 Third Party Advisory
lists.fedoraproject.org
text/html
URL Logo FEDORA FEDORA-2016-e1fe01e96e
Tell jQuery we're expecting JSON here · phpmyadmin/[email protected] · GitHub Patch
github.com
text/html
URL Logo CONFIRM github.com/phpmyadmin/phpmyadmin/commit/11496890d7e21786cbfd9fd17ab968f498116b3f

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
Operating
System
FedoraprojectFedora22AllAllAll
Operating
System
FedoraprojectFedora23AllAllAll
Operating
System
FedoraprojectFedora22AllAllAll
Operating
System
FedoraprojectFedora23AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.0AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.0.1AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.0.2AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.1AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.2AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.3AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.0AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.0.1AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.0.2AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.1AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.2AllAllAll
ApplicationPhpmyadminPhpmyadmin4.5.3AllAllAll
  • cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*:
  • cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*:
  • cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*:
  • cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3:*:*:*:*:*:*:*: