CVE-2016-2099

Published on: 05/13/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:16 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Certain versions of Xerces-c from Apache contain the following vulnerability:

Use-after-free vulnerability in validators/DTD/DTDScanner.cpp in Apache Xerces C++ 3.1.3 and earlier allows context-dependent attackers to have unspecified impact via an invalid character in an XML document.

  • CVE-2016-2099 has been assigned by [email protected] to track the vulnerability - currently rated as - currently rated as CRITICAL severity.

CVSS3 Score: 9.8 - CRITICAL

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 10 - HIGH

Access
Vector
Access
Complexity
Authentication
NETWORK LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
COMPLETE COMPLETE COMPLETE

CVE References

Description Tags Link
Debian -- Security Information -- DSA-3579-1 xerces-c www.debian.org
Depreciated Link
text/html
URL Logo DEBIAN DSA-3579
Apache Xerces CVE-2016-2099 Use-After-Free Remote Code Execution Vulnerability cve.report (archive)
text/html
URL Logo BID 90502
CPU July 2018 www.oracle.com
text/html
URL Logo CONFIRM www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
Xerces-C++: Multiple vulnerabilities (GLSA 201612-46) — Gentoo security security.gentoo.org
text/html
URL Logo GENTOO GLSA-201612-46
openSUSE-SU-2016:2232-1: moderate: Security update for xerces-c lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:2232
oss-security - CVE-2016-2099: use-after-free in Xerces 3.1.3 www.openwall.com
text/html
URL Logo MLIST [oss-security] 20160509 CVE-2016-2099: use-after-free in Xerces 3.1.3
[XERCESC-2066] Exception handling mistake in DTDScanner - ASF JIRA issues.apache.org
text/html
URL Logo CONFIRM issues.apache.org/jira/browse/XERCESC-2066
openSUSE-SU-2016:1744-1: moderate: Security update for xerces-c lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:1744
openSUSE-SU-2016:1808-1: moderate: Security update for xerces-c lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2016:1808

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationApacheXerces-c AllAllAllAll
Operating
System
OpensuseOpensuse13.2AllAllAll
Operating
System
OpensuseOpensuse13.2AllAllAll
  • cpe:2.3:a:apache:xerces-c\+\+:*:*:*:*:*:*:*:*:
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*:
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*: