CVE-2016-2193

Published on: 04/11/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:15 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Certain versions of Postgresql from Postgresql contain the following vulnerability:

PostgreSQL before 9.5.x before 9.5.2 does not properly maintain row-security status in cached plans, which might allow attackers to bypass intended access restrictions by leveraging a session that performs queries as more than one role.

  • CVE-2016-2193 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 7.5 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED NONE HIGH NONE

CVSS2 Score: 5 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE PARTIAL NONE

CVE References

Description Tags Link
PostgreSQL: Documentation: 9.5: Release 9.5.2 Vendor Advisory
www.postgresql.org
text/html
URL Logo CONFIRM www.postgresql.org/docs/current/static/release-9-5-2.html
PostgreSQL Bugs Let Remote Authenticated Users Access and Modify Data and Obtain Potentially Sensitive Information - SecurityTracker www.securitytracker.com
text/html
URL Logo SECTRACK 1035468
git.postgresql.org Git - postgresql.git/commitdiff git.postgresql.org
text/xml
URL Logo CONFIRM git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=db69e58a0642ef7fa46d62f6c4cf2460c3a1b41b
PostgreSQL: 2016-03-31 Security Update Release Patch
Vendor Advisory
www.postgresql.org
text/html
URL Logo CONFIRM www.postgresql.org/about/news/1656/

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationPostgresqlPostgresql9.5AllAllAll
ApplicationPostgresqlPostgresql9.5.1AllAllAll
ApplicationPostgresqlPostgresql9.5AllAllAll
ApplicationPostgresqlPostgresql9.5.1AllAllAll
  • cpe:2.3:a:postgresql:postgresql:9.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:postgresql:postgresql:9.5.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:postgresql:postgresql:9.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:postgresql:postgresql:9.5.1:*:*:*:*:*:*:*: