CVE-2016-4312

Published on: 02/16/2017 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:26:58 PM UTC

CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Certain versions of Identity Server from Wso2 contain the following vulnerability:

XML external entity (XXE) vulnerability in the XACML flow feature in WSO2 Identity Server 5.1.0 before WSO2-CARBON-PATCH-4.4.0-0231 allows remote authenticated users with access to XACML features to read arbitrary files, cause a denial of service, conduct server-side request forgery (SSRF) attacks, or have unspecified other impact via a crafted XACML request to entitlement/eval-policy-submit.jsp. NOTE: this issue can be combined with CVE-2016-4311 to exploit the vulnerability without credentials.

  • CVE-2016-4312 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 7.5 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK HIGH LOW NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
SecurityFocus www.securityfocus.com
text/html
URL Logo BUGTRAQ 20160813 WSO2 IDENTITY-SERVER v5.1.0 XML External-Entity
WSO2 Identity Server Cross Site Request Forgery and Information Disclosure Vulnerabilities Third Party Advisory
VDB Entry
cve.report (archive)
text/html
URL Logo BID 92485
WSO2 Identity Server 5.1.0 - Multiple Vulnerabilities Exploit
Third Party Advisory
VDB Entry
www.exploit-db.com
Proof of Concept
text/html
URL Logo EXPLOIT-DB 40239
Security Advisory WSO2-2016-0096 - WSO2 Platform Security - WSO2 Documentation Patch
Vendor Advisory
docs.wso2.com
text/html
URL Logo CONFIRM docs.wso2.com/display/Security/Security+Advisory+WSO2-2016-0096
Exploit
Third Party Advisory
hyp3rlinx.altervista.org
text/plain
MISC hyp3rlinx.altervista.org/advisories/WSO2-IDENTITY-SERVER-v5.1.0-XML-External-Entity.txt
WSO2 Identity Server 5.1.0 XML Injection ≈ Packet Storm Exploit
Third Party Advisory
VDB Entry
packetstormsecurity.com
text/html
URL Logo MISC packetstormsecurity.com/files/138329/WSO2-Identity-Server-5.1.0-XML-Injection.html

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationWso2Identity Server5.1.0AllAllAll
ApplicationWso2Identity Server5.1.0AllAllAll
  • cpe:2.3:a:wso2:identity_server:5.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:wso2:identity_server:5.1.0:*:*:*:*:*:*:*: