CVE-2016-4430

Published on: 07/04/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:26:59 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Certain versions of Struts from Apache contain the following vulnerability:

Apache Struts 2 2.3.20 through 2.3.28.1 mishandles token validation, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via unspecified vectors.

  • CVE-2016-4430 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 8.8 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE REQUIRED
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.8 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
No Description Provided VDB Entry
Vendor Advisory
jvndb.jvn.jp
text/html
URL Logo JVNDB JVNDB-2016-000111
S2-038 Vendor Advisory
struts.apache.org
text/html
URL Logo CONFIRM struts.apache.org/docs/s2-038.html
IBM Security Bulletin: Multiple Vulnerabilities in Struts v2 affect IBM Opportunity Detect - United States Third Party Advisory
web.archive.org
text/html
Inactive LinkNot Archived
URL Logo CONFIRM www-01.ibm.com/support/docview.wss?uid=swg21987854
IBM Security Bulletin: Multiple vulnerabilities in Apache Struts affect SAN Volume Controller and Storwize Family - United States Third Party Advisory
www-01.ibm.com
text/html
URL Logo CONFIRM www-01.ibm.com/support/docview.wss?uid=ssg1S1009282
1348249 – (CVE-2016-4430) CVE-2016-4430 struts: Bypassing token validation triggered by malicious expression Issue Tracking
bugzilla.redhat.com
text/html
URL Logo CONFIRM bugzilla.redhat.com/show_bug.cgi?id=1348249
Apache Struts CVE-2016-4430 Cross-Site Request Forgery Vulnerability cve.report (archive)
text/html
URL Logo BID 91281
Oracle Critical Patch Update - July 2017 www.oracle.com
text/html
URL Logo CONFIRM www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
JVN#45093481: Multiple vulnerabilities in Apache Struts 2 Vendor Advisory
jvn.jp
text/xml
URL Logo JVN JVN#45093481

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationApacheStruts2.3.20AllAllAll
ApplicationApacheStruts2.3.20.1AllAllAll
ApplicationApacheStruts2.3.20.3AllAllAll
ApplicationApacheStruts2.3.24AllAllAll
ApplicationApacheStruts2.3.24.1AllAllAll
ApplicationApacheStruts2.3.24.3AllAllAll
ApplicationApacheStruts2.3.28AllAllAll
ApplicationApacheStruts2.3.28.1AllAllAll
ApplicationApacheStruts2.3.20AllAllAll
ApplicationApacheStruts2.3.20.1AllAllAll
ApplicationApacheStruts2.3.20.3AllAllAll
ApplicationApacheStruts2.3.24AllAllAll
ApplicationApacheStruts2.3.24.1AllAllAll
ApplicationApacheStruts2.3.24.3AllAllAll
ApplicationApacheStruts2.3.28AllAllAll
ApplicationApacheStruts2.3.28.1AllAllAll
  • cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.28.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.20:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.20.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.20.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.24:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.24.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.24.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.28:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:struts:2.3.28.1:*:*:*:*:*:*:*: