CVE-2016-4519

Published on: 06/24/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:26:58 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Certain versions of Visilogic Oplc Ide from Unitronics contain the following vulnerability:

Stack-based buffer overflow in Unitronics VisiLogic OPLC IDE before 9.8.30 allows remote attackers to execute arbitrary code via a crafted filename field in a ZIP archive in a vlp file.

  • CVE-2016-4519 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as - currently rated as CRITICAL severity.

CVSS3 Score: 9.8 - CRITICAL

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 7.5 - HIGH

Access
Vector
Access
Complexity
Authentication
NETWORK LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Unitronics VisiLogic CVE-2016-4519 Stack Buffer Overflow Vulnerability cve.report (archive)
text/html
URL Logo BID 91402
Zero Day Initiative Vendor Advisory
zerodayinitiative.com
text/html
URL Logo MISC zerodayinitiative.com/advisories/ZDI-16-375/
Unitronics VisiLogic OPLC IDE vlp File Parsing Stack Buffer Overflow Vulnerability | ICS-CERT Third Party Advisory
US Government Resource
ics-cert.us-cert.gov
text/html
URL Logo MISC ics-cert.us-cert.gov/advisories/ICSA-16-175-02

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationUnitronicsVisilogic Oplc IdeAllAllAllAll
  • cpe:2.3:a:unitronics:visilogic_oplc_ide:*:*:*:*:*:*:*:*: