CVE-2016-4977

Published on: 05/25/2017 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:26:58 PM UTC

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Certain versions of Spring Security Oauth from Pivotal contain the following vulnerability:

When processing authorization requests using the whitelabel views in Spring Security OAuth 2.0.0 to 2.0.9 and 1.0.0 to 1.0.5, the response_type parameter value was executed as Spring SpEL which enabled a malicious user to trigger remote code execution via the crafting of the value for response_type.

  • CVE-2016-4977 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.
  • Affected Vendor/Software: Pivotal - Spring Security OAuth version 2.0.0 to 2.0.9
  • Affected Vendor/Software: Pivotal - Spring Security OAuth version 1.0.0 to 1.0.5

CVSS3 Score: 8.8 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW LOW NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.5 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Pony Mail! lists.apache.org
text/html
URL Logo MLIST [fineract-dev] 20191016 Re: [CVE-2016-4977] Apache Fineract remote code execution vulnerabilities fixed in v1.3.0
Pony Mail! lists.apache.org
text/html
URL Logo MLIST [fineract-dev] 20191016 [CVE-2016-4977] Apache Fineract remote code execution vulnerabilities fixed in v1.3.0
CVE-2016-4977 Remote Code Execution (RCE) in Spring Security OAuth | Security | Pivotal Vendor Advisory
pivotal.io
text/html
URL Logo CONFIRM pivotal.io/security/cve-2016-4977
Pony Mail! lists.apache.org
text/html
URL Logo MLIST [fineract-dev] 20191021 Re: [CVE-2016-4977] Apache Fineract remote code execution vulnerabilities fixed in v1.3.0
oss-security - Fwd: [CVE-2016-4977] Apache Fineract remote code execution vulnerabilities fixed in v1.3.0 www.openwall.com
text/html
URL Logo MLIST [oss-security] 20191015 Fwd: [CVE-2016-4977] Apache Fineract remote code execution vulnerabilities fixed in v1.3.0
Pony Mail! lists.apache.org
text/html
URL Logo MLIST [announce] 20191016 [CVE-2016-4977] Apache Fineract remote code execution vulnerabilities fixed in v1.3.0

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationPivotalSpring Security Oauth1.0.0AllAllAll
ApplicationPivotalSpring Security Oauth1.0.1AllAllAll
ApplicationPivotalSpring Security Oauth1.0.2AllAllAll
ApplicationPivotalSpring Security Oauth1.0.3AllAllAll
ApplicationPivotalSpring Security Oauth1.0.4AllAllAll
ApplicationPivotalSpring Security Oauth1.0.5AllAllAll
ApplicationPivotalSpring Security Oauth2.0.0AllAllAll
ApplicationPivotalSpring Security Oauth2.0.1AllAllAll
ApplicationPivotalSpring Security Oauth2.0.2AllAllAll
ApplicationPivotalSpring Security Oauth2.0.3AllAllAll
ApplicationPivotalSpring Security Oauth2.0.4AllAllAll
ApplicationPivotalSpring Security Oauth2.0.5AllAllAll
ApplicationPivotalSpring Security Oauth2.0.6AllAllAll
ApplicationPivotalSpring Security Oauth2.0.7AllAllAll
ApplicationPivotalSpring Security Oauth2.0.8AllAllAll
ApplicationPivotalSpring Security Oauth2.0.9AllAllAll
ApplicationPivotalSpring Security Oauth1.0.0AllAllAll
ApplicationPivotalSpring Security Oauth1.0.1AllAllAll
ApplicationPivotalSpring Security Oauth1.0.2AllAllAll
ApplicationPivotalSpring Security Oauth1.0.3AllAllAll
ApplicationPivotalSpring Security Oauth1.0.4AllAllAll
ApplicationPivotalSpring Security Oauth1.0.5AllAllAll
ApplicationPivotalSpring Security Oauth2.0.0AllAllAll
ApplicationPivotalSpring Security Oauth2.0.1AllAllAll
ApplicationPivotalSpring Security Oauth2.0.2AllAllAll
ApplicationPivotalSpring Security Oauth2.0.3AllAllAll
ApplicationPivotalSpring Security Oauth2.0.4AllAllAll
ApplicationPivotalSpring Security Oauth2.0.5AllAllAll
ApplicationPivotalSpring Security Oauth2.0.6AllAllAll
ApplicationPivotalSpring Security Oauth2.0.7AllAllAll
ApplicationPivotalSpring Security Oauth2.0.8AllAllAll
ApplicationPivotalSpring Security Oauth2.0.9AllAllAll
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.4:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.4:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.6:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.7:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.8:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.9:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.4:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:1.0.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.2:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.3:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.4:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.5:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.6:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.7:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.8:*:*:*:*:*:*:*:
  • cpe:2.3:a:pivotal:spring_security_oauth:2.0.9:*:*:*:*:*:*:*: