CVE-2016-4985

Published on: 07/12/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:26:58 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Certain versions of Openstack Ironic from Canonical contain the following vulnerability:

The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.

  • CVE-2016-4985 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 7.5 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH NONE NONE

CVSS2 Score: 5 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL NONE NONE

CVE References

Description Tags Link
oss-security - Ironic node information including credentials exposed to unathenticated users www.openwall.com
text/html
URL Logo MLIST [oss-security] 20160621 Ironic node information including credentials exposed to unathenticated users
Red Hat Customer Portal access.redhat.com
text/html
URL Logo REDHAT RHSA-2016:1378
Gerrit Code Review review.openstack.org
text/html
URL Logo CONFIRM review.openstack.org/332195
Gerrit Code Review review.openstack.org
text/html
URL Logo CONFIRM review.openstack.org/332197
Gerrit Code Review review.openstack.org
text/html
URL Logo CONFIRM review.openstack.org/332196
Red Hat Customer Portal access.redhat.com
text/html
URL Logo REDHAT RHSA-2016:1377
Bug #1572796 “Node information including credentials exposed to...” : Bugs : Ironic Vendor Advisory
bugs.launchpad.net
text/html
URL Logo CONFIRM bugs.launchpad.net/ironic/+bug/1572796

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationCanonicalOpenstack Ironic5.1.0AllAllAll
ApplicationCanonicalOpenstack Ironic5.1.1AllAllAll
ApplicationCanonicalOpenstack Ironic5.1.0AllAllAll
ApplicationCanonicalOpenstack Ironic5.1.1AllAllAll
ApplicationCanonicalOpenstack IronicAllAllAllAll
ApplicationRedhatOpenstack7.0AllAllAll
ApplicationRedhatOpenstack8.0AllAllAll
ApplicationRedhatOpenstack7.0AllAllAll
ApplicationRedhatOpenstack8.0AllAllAll
  • cpe:2.3:a:canonical:openstack_ironic:5.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:canonical:openstack_ironic:5.1.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:canonical:openstack_ironic:5.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:canonical:openstack_ironic:5.1.1:*:*:*:*:*:*:*:
  • cpe:2.3:a:canonical:openstack_ironic:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:redhat:openstack:7.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:redhat:openstack:8.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:redhat:openstack:7.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:redhat:openstack:8.0:*:*:*:*:*:*:*: