CVE-2016-7054

Published on: 05/04/2017 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:06 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Certain versions of Openssl from Openssl contain the following vulnerability:

In OpenSSL 1.1.0 before 1.1.0c, TLS connections using *-CHACHA20-POLY1305 ciphersuites are susceptible to a DoS attack by corrupting larger payloads. This can result in an OpenSSL crash. This issue is not considered to be exploitable beyond a DoS.

  • CVE-2016-7054 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.
  • Affected Vendor/Software: OpenSSL - OpenSSL version openssl-1.1.0
  • Affected Vendor/Software: OpenSSL - OpenSSL version openssl-1.1.0a
  • Affected Vendor/Software: OpenSSL - OpenSSL version openssl-1.1.0b

CVSS3 Score: 7.5 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED NONE NONE HIGH

CVSS2 Score: 5 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE NONE PARTIAL

CVE References

Description Tags Link
OpenSSL CVE-2016-7054 Denial of Service Vulnerability Third Party Advisory
VDB Entry
cve.report (archive)
text/html
URL Logo BID 94238
Patch
Vendor Advisory
www.openssl.org
text/plain
CONFIRM www.openssl.org/news/secadv/20161110.txt
OpenSSL 1.1.0a/1.1.0b - Denial of Service - Linux dos Exploit www.exploit-db.com
Proof of Concept
text/html
URL Logo EXPLOIT-DB 40899
OpenSSL Multiple Bugs Let Remote Users Cause the Target Application to Crash - SecurityTracker www.securitytracker.com
text/html
URL Logo SECTRACK 1037261
Document Display | HPE Support Center h20566.www2.hpe.com
text/html
URL Logo CONFIRM h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03744en_us

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationOpensslOpenssl1.1.0AllAllAll
ApplicationOpensslOpenssl1.1.0aAllAllAll
ApplicationOpensslOpenssl1.1.0bAllAllAll
ApplicationOpensslOpenssl1.1.0AllAllAll
ApplicationOpensslOpenssl1.1.0aAllAllAll
ApplicationOpensslOpenssl1.1.0bAllAllAll
  • cpe:2.3:a:openssl:openssl:1.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:openssl:openssl:1.1.0a:*:*:*:*:*:*:*:
  • cpe:2.3:a:openssl:openssl:1.1.0b:*:*:*:*:*:*:*:
  • cpe:2.3:a:openssl:openssl:1.1.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:openssl:openssl:1.1.0a:*:*:*:*:*:*:*:
  • cpe:2.3:a:openssl:openssl:1.1.0b:*:*:*:*:*:*:*:

Discovery Credit

Robert Święcki (Google Security Team)