CVE-2016-7249

Published on: 11/10/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:06 PM UTC

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Certain versions of Sql Server from Microsoft contain the following vulnerability:

Microsoft SQL Server 2016 does not properly perform a cast of an unspecified pointer, which allows remote authenticated users to gain privileges via unknown vectors, aka "SQL RDBMS Engine Elevation of Privilege Vulnerability."

  • CVE-2016-7249 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.

CVSS3 Score: 8.8 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW LOW NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.5 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Microsoft Security Bulletin MS16-136 - Important | Microsoft Docs docs.microsoft.com
text/html
URL Logo MS MS16-136
Microsoft SQL Server Flaws Let Remote Users Conduct Cross-Site Scripting Attacks and Remote Authenticated Users Obtain Potentially Sensitive Information and Gain Elevated Privileges - SecurityTracker www.securitytracker.com
text/html
URL Logo SECTRACK 1037250
Microsoft SQL Server CVE-2016-7249 Privilege Escalation Vulnerability cve.report (archive)
text/html
URL Logo BID 94037

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationMicrosoftSql Server2016AllAllAll
ApplicationMicrosoftSql Server2016AllAllAll
  • cpe:2.3:a:microsoft:sql_server:2016:*:*:*:*:*:*:*:
  • cpe:2.3:a:microsoft:sql_server:2016:*:*:*:*:*:*:*: