CVE-2019-11744

Published on: 09/27/2019 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:37 PM UTC

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Certain versions of Firefox from Mozilla contain the following vulnerability:

Some HTML elements, such as &lt;title&gt; and &lt;textarea&gt;, can contain literal angle brackets without treating them as markup. It is possible to pass a literal closing tag to .innerHTML on these elements, and subsequent content after that will be parsed as if it were outside the tag. This can lead to XSS if a site does not filter user input as strictly for these elements as it does for other elements. This vulnerability affects Firefox < 69, Thunderbird < 68.1, Thunderbird < 60.9, Firefox ESR < 60.9, and Firefox ESR < 68.1.

  • CVE-2019-11744 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as MEDIUM severity.
  • Affected Vendor/Software: URL Logo Mozilla - Firefox version < 69
  • Affected Vendor/Software: URL Logo Mozilla - Thunderbird version < 68.1
  • Affected Vendor/Software: URL Logo Mozilla - Thunderbird version < 60.9
  • Affected Vendor/Software: URL Logo Mozilla - Firefox ESR version < 60.9
  • Affected Vendor/Software: URL Logo Mozilla - Firefox ESR version < 68.1

CVSS3 Score: 6.1 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE REQUIRED
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
CHANGED LOW LOW NONE

CVSS2 Score: 4.3 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE PARTIAL NONE

CVE References

Description Tags Link
Mozilla Firefox: Multiple vulnerabilities (GLSA 201911-07) — Gentoo security security.gentoo.org
text/html
URL Logo GENTOO GLSA-201911-07
Security vulnerabilities fixed in Firefox 69 — Mozilla Vendor Advisory
www.mozilla.org
text/html
URL Logo CONFIRM www.mozilla.org/security/advisories/mfsa2019-25/
Security vulnerabilities fixed in Firefox ESR 68.1 — Mozilla Vendor Advisory
www.mozilla.org
text/html
URL Logo CONFIRM www.mozilla.org/security/advisories/mfsa2019-26/
1562033 - (CVE-2019-11744) title.innerHTML = "" parses as a tag Issue Tracking
Permissions Required
Vendor Advisory
bugzilla.mozilla.org
text/html
URL Logo MISC bugzilla.mozilla.org/show_bug.cgi?id=1562033
[security-announce] openSUSE-SU-2019:2251-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2019:2251
USN-4150-1: Thunderbird vulnerabilities | Ubuntu security notices | Ubuntu usn.ubuntu.com
text/html
URL Logo UBUNTU USN-4150-1
Security vulnerabilities fixed in - Thunderbird 68.1 — Mozilla Vendor Advisory
www.mozilla.org
text/html
URL Logo CONFIRM www.mozilla.org/security/advisories/mfsa2019-30/
Security vulnerabilities fixed in Firefox ESR 60.9 — Mozilla Vendor Advisory
www.mozilla.org
text/html
URL Logo CONFIRM www.mozilla.org/security/advisories/mfsa2019-27/
[security-announce] openSUSE-SU-2019:2249-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2019:2249
Security vulnerabilities fixed in - Thunderbird 60.9 — Mozilla Vendor Advisory
www.mozilla.org
text/html
URL Logo CONFIRM www.mozilla.org/security/advisories/mfsa2019-29/
[security-announce] openSUSE-SU-2019:2260-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2019:2260
[security-announce] openSUSE-SU-2019:2248-1: important: Security update lists.opensuse.org
text/html
URL Logo SUSE openSUSE-SU-2019:2248

Related QID Numbers

  • 500921 Alpine Linux Security Update for firefox-esr
  • 710116 Gentoo Linux Mozilla Firefox Multiple vulnerabilities (GLSA 201911-07)

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationMozillaFirefoxAllAllAllAll
ApplicationMozillaFirefoxAllAllAllAll
ApplicationMozillaFirefox EsrAllAllAllAll
ApplicationMozillaFirefox EsrAllAllAllAll
ApplicationMozillaThunderbirdAllAllAllAll
ApplicationMozillaThunderbirdAllAllAllAll
  • cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:*:
© CVE.report 2022 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report