CVE-2020-36322

Published on: 04/14/2021 12:00:00 AM UTC

Last Modified on: 10/14/2022 06:56:00 PM UTC

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Certain versions of Debian Linux from Debian contain the following vulnerability:

An issue was discovered in the FUSE filesystem implementation in the Linux kernel before 5.10.6, aka CID-5d069dbe8aaf. fuse_do_getattr() calls make_bad_inode() in inappropriate situations, causing a system crash. NOTE: the original fix for this vulnerability was incomplete, and its incompleteness is tracked as CVE-2021-28950.

  • CVE-2020-36322 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as MEDIUM severity.

CVSS3 Score: 5.5 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
LOCAL LOW LOW NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED NONE NONE HIGH

CVSS2 Score: 4.9 - MEDIUM

Access
Vector
Access
Complexity
Authentication
LOCAL LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE NONE COMPLETE

CVE References

Description Tags Link
[SECURITY] [DLA 2941-1] linux-4.19 security update lists.debian.org
text/html
URL Logo MLIST [debian-lts-announce] 20220309 [SECURITY] [DLA 2941-1] linux-4.19 security update
CVE-2020-36322 Linux kernel vulnerability in StarWind products www.starwindsoftware.com
text/html
URL Logo MISC www.starwindsoftware.com/security/sw-20220816-0001/
[SECURITY] [DLA 2689-1] linux security update lists.debian.org
text/html
URL Logo MLIST [debian-lts-announce] 20210623 [SECURITY] [DLA 2689-1] linux security update
kernel/git/torvalds/linux.git - Linux kernel source tree git.kernel.org
text/html
URL Logo MISC git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=5d069dbe8aaf2a197142558b6fb2978189ba3454
cdn.kernel.org
text/plain
URL Logo MISC cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.6
Debian -- Security Information -- DSA-5096-1 linux www.debian.org
Depreciated Link
text/html
URL Logo DEBIAN DSA-5096

Related QID Numbers

  • 159185 Oracle Enterprise Linux Security Update for kernel (ELSA-2021-1578)
  • 159402 Oracle Enterprise Linux Security Update for Unbreakable Enterprise kernel-container (ELSA-2021-9458)
  • 159404 Oracle Enterprise Linux Security Update for Unbreakable Enterprise kernel (ELSA-2021-9460)
  • 159424 Oracle Enterprise Linux Security Update for Unbreakable Enterprise kernel (ELSA-2021-9485)
  • 159427 Oracle Enterprise Linux Security Update for Unbreakable Enterprise kernel-container (ELSA-2021-9488)
  • 159588 Oracle Enterprise Linux Security Update for kernel (ELSA-2022-0063)
  • 174919 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1238-1)
  • 174996 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:14724-1)
  • 178680 Debian Security Update for linux (DLA 2689-1)
  • 179117 Debian Security Update for linux (DSA 5096-1)
  • 179119 Debian Security Update for linux-4.19 (DLA 2941-1)
  • 198562 Ubuntu Security Notification for Linux kernel Vulnerabilities (USN-5136-1)
  • 239339 Red Hat Update for kernel (RHSA-2021:1578)
  • 239989 Red Hat Update for kernel-rt (RHSA-2022:0065)
  • 239992 Red Hat Update for kernel-rt (RHSA-2022:0078)
  • 239994 Red Hat Update for kernel (RHSA-2022:0072)
  • 239997 Red Hat Update for kernel (RHSA-2022:0063)
  • 257142 CentOS Security Update for kernel (CESA-2022:0063)
  • 257144 CentOS Security Update for kernel (CESA-2022:0063)
  • 353184 Amazon Linux Security Advisory for kernel : ALAS-2022-1571
  • 353195 Amazon Linux Security Advisory for kernel : ALAS2-2022-1761
  • 353242 Amazon Linux Security Advisory for kernel : ALAC2012-2022-036
  • 353243 Amazon Linux Security Advisory for kmod-mlx5 : ALAC2012-2022-037
  • 353244 Amazon Linux Security Advisory for kmod-sfc : ALAC2012-2022-038
  • 670416 EulerOS Security Update for kernel (EulerOS-SA-2021-1983)
  • 670438 EulerOS Security Update for kernel (EulerOS-SA-2021-2062)
  • 670449 EulerOS Security Update for kernel (EulerOS-SA-2021-2051)
  • 670578 EulerOS Security Update for kernel (EulerOS-SA-2021-2336)
  • 670634 EulerOS Security Update for kernel (EulerOS-SA-2021-2392)
  • 671252 EulerOS Security Update for kernel (EulerOS-SA-2022-1171)
  • 750001 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1572-1)
  • 750004 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1573-1)
  • 750005 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1595-1)
  • 750006 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1596-1)
  • 750014 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1623-1)
  • 750015 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1624-1)
  • 750031 SUSE Enterprise Linux Security Update for the Linux Kernel (Live Patch 22 for SLE 15) (SUSE-SU-2021:1728-1)
  • 750032 SUSE Enterprise Linux Security Update for the Linux Kernel (Live Patch 23 for SLE 15 SP1) (SUSE-SU-2021:1715-1)
  • 750034 SUSE Enterprise Linux Security Update for the Linux Kernel (Live Patch 14 for SLE 15 SP1) (SUSE-SU-2021:1724-1)
  • 750111 SUSE Enterprise Linux Security Update for the Linux Kernel (Live Patch 35 for SLE 12 SP3) (SUSE-SU-2021:1865-1)
  • 750112 SUSE Enterprise Linux Security Update for the Linux Kernel (Live Patch 37 for SLE 12 SP3) (SUSE-SU-2021:1870-1)
  • 750261 OpenSUSE Security Update for the Linux Kernel (openSUSE-SU-2021:0579-1)
  • 750650 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1975-1)
  • 750652 SUSE Enterprise Linux Security Update for the Linux Kernel (SUSE-SU-2021:1977-1)
  • 750762 OpenSUSE Security Update for the Linux Kernel (openSUSE-SU-2021:1977-1)
  • 750766 OpenSUSE Security Update for the Linux Kernel (openSUSE-SU-2021:1975-1)
  • 940354 AlmaLinux Security Update for kernel (ALSA-2021:1578)

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
Operating
System
DebianDebian Linux10.0AllAllAll
Operating
System
DebianDebian Linux9.0AllAllAll
Operating
System
LinuxLinux KernelAllAllAllAll
ApplicationStarwindsoftwareStarwind Virtual San814338AllAll
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*:
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*:
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:starwindsoftware:starwind_virtual_san:8:14338:*:*:*:*:*:*:

Social Mentions

Source Title Posted (UTC)
Twitter Icon @CVEreport CVE-2020-36322 : An issue was discovered in the FUSE filesystem implementation in the #Linux #kernel before 5.10.6,… twitter.com/i/web/status/1… 2021-04-14 05:47:00
Twitter Icon @LinInfoSec Git - CVE-2020-36322: cdn.kernel.org/pub/linux/kern… 2021-04-14 11:20:19
Twitter Icon @FortifiedITLtd CVE-2020-36322 An issue was discovered in the FUSE filesystem implementation in the Linux kernel before 5.10.6, aka… twitter.com/i/web/status/1… 2021-04-23 19:01:09
Reddit Logo Icon /r/netcve CVE-2020-36322 2021-04-14 06:00:21
© CVE.report 2023 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report