CVE-2021-2388

Published on: 07/20/2021 12:00:00 AM UTC

Last Modified on: 10/20/2021 11:16:00 AM UTC

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Certain versions of Debian Linux from Debian contain the following vulnerability:

Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 8u291, 11.0.11, 16.0.1; Oracle GraalVM Enterprise Edition: 20.3.2 and 21.1.0. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in takeover of Java SE, Oracle GraalVM Enterprise Edition. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H).

  • CVE-2021-2388 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as HIGH severity.
  • Affected Vendor/Software: URL Logo Oracle Corporation - Java SE JDK and JRE version = Java SE:8u291
  • Affected Vendor/Software: URL Logo Oracle Corporation - Java SE JDK and JRE version = Java SE:11.0.11
  • Affected Vendor/Software: URL Logo Oracle Corporation - Java SE JDK and JRE version = Java SE:16.0.1
  • Affected Vendor/Software: URL Logo Oracle Corporation - Java SE JDK and JRE version = Oracle GraalVM Enterprise Edition:20.3.2
  • Affected Vendor/Software: URL Logo Oracle Corporation - Java SE JDK and JRE version = Oracle GraalVM Enterprise Edition:21.1.0

CVSS3 Score: 7.5 - HIGH

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK HIGH NONE REQUIRED
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 5.1 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK HIGH NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Oracle Critical Patch Update Advisory - July 2021 www.oracle.com
text/html
URL Logo MISC www.oracle.com/security-alerts/cpujul2021.html
Debian -- Security Information -- DSA-4946-1 openjdk-11 www.debian.org
Depreciated Link
text/html
URL Logo DEBIAN DSA-4946
July 2021 Java Platform Standard Edition Vulnerabilities in NetApp Products | NetApp Product Security Third Party Advisory
security.netapp.com
text/html
URL Logo CONFIRM security.netapp.com/advisory/ntap-20210723-0002/
Oracle Critical Patch Update Advisory - October 2021 www.oracle.com
text/html
URL Logo MISC www.oracle.com/security-alerts/cpuoct2021.html
[SECURITY] [DLA 2737-1] openjdk-8 security update lists.debian.org
text/html
URL Logo MLIST [debian-lts-announce] 20210809 [SECURITY] [DLA 2737-1] openjdk-8 security update

Related QID Numbers

  • 159311 Oracle Enterprise Linux Security Update for java-11-openjdk (ELSA-2021-2784)
  • 159312 Oracle Enterprise Linux Security Update for java-1.8.0-openjdk (ELSA-2021-2845)
  • 159313 Oracle Enterprise Linux Security Update for java-1.8.0-openjdk (ELSA-2021-2776)
  • 159314 Oracle Enterprise Linux Security Update for java-11-openjdk (ELSA-2021-2781)
  • 178728 Debian Security Update for openjdk-11 (DSA 4946-1)
  • 178749 Debian Security Update for openjdk-8 (DLA 2737-1)
  • 239512 Red Hat Update for java-1.8.0-openjdk (RHSA-2021:2845)
  • 239513 Red Hat Update for java-11-openjdk (RHSA-2021:2784)
  • 239514 Red Hat Update for java-11-openjdk (RHSA-2021:2783)
  • 239515 Red Hat Update for java-11-openjdk (RHSA-2021:2782)
  • 239516 Red Hat Update for java-11-openjdk (RHSA-2021:2781)
  • 239517 Red Hat Update for java-1.8.0-openjdk (RHSA-2021:2776)
  • 239518 Red Hat Update for java-1.8.0-openjdk (RHSA-2021:2775)
  • 239519 Red Hat Update for java-1.8.0-openjdk (RHSA-2021:2774)
  • 257099 CentOS Security Update for java-11-openjdk (CESA-2021:2784)
  • 257103 CentOS Security Update for java-1.8.0-openjdk Security Update (CESA-2021:2845)
  • 281768 Fedora Security Update for java (FEDORA-2021-e6b0792d75)
  • 281769 Fedora Security Update for java (FEDORA-2021-4581ccb97d)
  • 281770 Fedora Security Update for java (FEDORA-2021-ade03666c0)
  • 281771 Fedora Security Update for java (FEDORA-2021-d20d6712bc)
  • 352499 Amazon Linux Security Advisory for java-11-amazon-corretto: ALAS2-2021-1692
  • 352504 Amazon Linux Security Advisory for java-1.8.0-openjdk: ALAS2-2021-1695
  • 352807 Amazon Linux Security Advisory for java-1.8.0-openjdk: ALAS-2021-1528
  • 375729 Oracle Java SE Critical Patch Update - July 2021 (CPUJUL2021)
  • 375817 Azul Java Multiple Vulnerabilities Security Update July 2021
  • 375986 Amazon Corretto Critical Patch Update (JUL2021)
  • 670706 EulerOS Security Update for java-1.8.0-openjdk (EulerOS-SA-2021-2464)
  • 670743 EulerOS Security Update for java-1.8.0-openjdk (EulerOS-SA-2021-2501)
  • 671053 EulerOS Security Update for java-1.8.0-openjdk (EulerOS-SA-2021-2587)
  • 730206 McAfee Web Gateway Multiple Vulnerabilities (WP-3792, WP-4003, WP-4021, WP-4058, WP-4067)
  • 750921 SUSE Enterprise Linux Security Update for java-11-openjdk (SUSE-SU-2021:2613-1)
  • 750983 SUSE Enterprise Linux Security Update for java-1_8_0-openjdk (SUSE-SU-2021:2797-1)
  • 750988 SUSE Enterprise Linux Security Update for java-1_8_0-openjdk (SUSE-SU-2021:2798-1)
  • 751006 OpenSUSE Security Update for java-1_8_0-openjdk (openSUSE-SU-2021:1176-1)
  • 751010 OpenSUSE Security Update for java-1_8_0-openjdk (openSUSE-SU-2021:2798-1)
  • 751084 SUSE Enterprise Linux Security Update for java-11-openJava Development Toolkit (SUSE-SU-2021:2952-1)
  • 751094 OpenSUSE Security Update for java-11-openJava Development Toolkit (openSUSE-SU-2021:2952-1)
  • 751115 OpenSUSE Security Update for java-11-openJava Development Toolkit (openSUSE-SU-2021:1233-1)
  • 751326 OpenSUSE Security Update for java-1_8_0-openj9 (openSUSE-SU-2021:1455-1)
  • 751329 OpenSUSE Security Update for java-1_8_0-openj9 (openSUSE-SU-2021:3615-1)

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
Operating
System
DebianDebian Linux10.0AllAllAll
Operating
System
DebianDebian Linux9.0AllAllAll
ApplicationOracleGraalvm20.3.2AllAllAll
ApplicationOracleGraalvm21.1.0AllAllAll
ApplicationOracleJdk1.8.0update291AllAll
ApplicationOracleJdk11.0.11AllAllAll
ApplicationOracleJdk16.0.1AllAllAll
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*:
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*:
  • cpe:2.3:a:oracle:graalvm:20.3.2:*:*:*:enterprise:*:*:*:
  • cpe:2.3:a:oracle:graalvm:21.1.0:*:*:*:enterprise:*:*:*:
  • cpe:2.3:a:oracle:jdk:1.8.0:update291:*:*:*:*:*:*:
  • cpe:2.3:a:oracle:jdk:11.0.11:*:*:*:*:*:*:*:
  • cpe:2.3:a:oracle:jdk:16.0.1:*:*:*:*:*:*:*:

Social Mentions

Source Title Posted (UTC)
Twitter Icon @spiegel_2007 Java 16.0.2 出てる。公表されてる脆弱性情報は4つ: CVE-2021-2341 CVE-2021-2369 CVE-2021-2388 CVE-2021-2432 2021-07-20 21:20:19
Twitter Icon @CVEreport CVE-2021-2388 : Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE componen… twitter.com/i/web/status/1… 2021-07-20 23:11:15
Twitter Icon @sec_trend Oracle Java の脆弱性対策について(CVE-2021-2388等) izumino.jp/Security/sec_t… ipa.go.jp/security/ciadr… 2021-07-21 03:00:26
Twitter Icon @itsec_jp IPA 重要 | Oracle Java の脆弱性対策について(CVE-2021-2388等) ift.tt/2UXEaU0 #itsec_jp 2021-07-21 03:04:32
Twitter Icon @SecurityOsaka Oracle Java の脆弱性対策について(CVE-2021-2388等) | IPAセキュリティセンター:重要なセキュリティ情報 IPAセキュリティセンター:重要なセキュリティ情報 July 21, 2021 at 12:00… twitter.com/i/web/status/1… 2021-07-21 03:07:33
Twitter Icon @TokyoSec Oracle Java の脆弱性対策について(CVE-2021-2388等) dlvr.it/S46svD 2021-07-21 03:10:03
Twitter Icon @securenews_web Oracle Java の脆弱性対策について(CVE-2021-2388等) - IPA [securenews.appsight.net/entries/13127] ipa.go.jp/security/ciadr… 2021-07-21 03:11:08
Twitter Icon @gesuno_jp Oracle Java の脆弱性対策について(CVE-2021-2388等)ift.tt/2UXEaU0 2021-07-21 03:40:48
Twitter Icon @jexens Oracle Java の脆弱性対策について(CVE-2021-2388等) ift.tt/2UXEaU0 2021-07-21 03:43:34
Twitter Icon @revision_pr Oracle Java の脆弱性対策について(CVE-2021-2388等) ipa.go.jp/security/ciadr… 2021-07-21 05:21:47
Twitter Icon @ICATalerts Oracle Java の脆弱性対策について(CVE-2021-2388等) dlvr.it/S476T3 2021-07-21 05:27:02
Twitter Icon @itsec_jp ICATalerts: Oracle Java の脆弱性対策について(CVE-2021-2388等) dlvr.it/S476T3 twitter.com/ICATalerts/sta… #itsec_jp 2021-07-21 05:33:08
Twitter Icon @yyano Oracle Java の脆弱性対策について(CVE-2021-2388等):IPA 独立行政法人 情報処理推進機構 ipa.go.jp/security/ciadr… 2021-07-21 07:38:21
Twitter Icon @ohhara_shiojiri Oracle Java の脆弱性対策について(CVE-2021-2388等):IPA 独立行政法人 情報処理推進機構 ipa.go.jp/security/ciadr… 2021-07-21 08:56:01
Twitter Icon @ipssignatures The vuln CVE-2021-2388 has a tweet created 0 days ago and retweeted 18 times. twitter.com/ICATalerts/sta… #pow1rtrtwwcve 2021-07-21 11:06:00
Twitter Icon @Yamaguchi4869 Oracle Java の脆弱性対策について(CVE-2021-2388等):IPA 独立行政法人 情報処理推進機構 ipa.go.jp/security/ciadr… 2021-07-21 11:16:52
Twitter Icon @ottoto2017 #OpenJDK 16 でCVE-2021-2388,CVE-2021-2369,CVE-2021-2341へのセキュリティ対応があり、16.0.2 に update した。#Tomcat の再起動が必要なので告知してからの up… twitter.com/i/web/status/1… 2021-07-23 05:33:07
Reddit Logo Icon /r/jep411 CVE-2021-2388 2021-08-26 00:52:55
Reddit Logo Icon /r/java Our platform is not on sandbox. Is it okay to forget about CVE-2021-2388? 2021-08-26 12:15:48
© CVE.report 2021 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report