CVE-2021-32790

Published on: 07/26/2021 12:00:00 AM UTC

Last Modified on: 08/04/2021 07:49:00 PM UTC

CVE-2021-32790 - advisory for GHSA-7vx5-x39w-q24g

Source: Mitre Source: Nist Print: PDF PDF
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Certain versions of Woocommerce from Woocommerce contain the following vulnerability:

Woocommerce is an open source eCommerce plugin for WordPress. An SQL injection vulnerability impacts all WooCommerce sites running the WooCommerce plugin between version 3.3.0 and 3.3.6. Malicious actors (already) having admin access, or API keys to the WooCommerce site can exploit vulnerable endpoints of `/wp-json/wc/v3/webhooks`, `/wp-json/wc/v2/webhooks` and other webhook listing API. Read-only SQL queries can be executed using this exploit, while data will not be returned, by carefully crafting `search` parameter information can be disclosed using timing and related attacks. Version 3.3.6 is the earliest version of Woocommerce with a patch for this vulnerability. There are no known workarounds other than upgrading.

  • CVE-2021-32790 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as MEDIUM severity.
  • Affected Vendor/Software: URL Logo woocommerce - woocommerce version >= 3.3.0, < 3.3.6

CVSS3 Score: 4.9 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW HIGH NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH NONE NONE

CVSS2 Score: 4 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK LOW SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL NONE NONE

CVE References

Description Tags Link
Blind SQL Injection possible via Authenticated Web-hook Search API Endpoint · Advisory · woocommerce/woocommerce · GitHub github.com
text/html
URL Logo CONFIRM github.com/woocommerce/woocommerce/security/advisories/GHSA-7vx5-x39w-q24g
Critical Vulnerabilty Detected in WooCommerce - What You Need to Know woocommerce.com
text/html
URL Logo MISC woocommerce.com/posts/critical-vulnerability-detected-july-2021/

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationWoocommerceWoocommerceAllAllAllAll
  • cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:*:

Social Mentions

Source Title Posted (UTC)
Twitter Icon @CVEreport CVE-2021-32790 : Woocommerce is an open source eCommerce plugin for WordPress. An SQL injection vulnerability impac… twitter.com/i/web/status/1… 2021-07-26 16:34:54
© CVE.report 2021 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report