CVE-2021-41266

Published on: 11/15/2021 12:00:00 AM UTC

Last Modified on: 11/19/2021 04:16:00 PM UTC

CVE-2021-41266 - advisory for GHSA-4999-659w-mq36

Source: Mitre Source: Nist Print: PDF PDF
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Certain versions of Minio Console from Min contain the following vulnerability:

Minio console is a graphical user interface for the for MinIO operator. Minio itself is a multi-cloud object storage project. Affected versions are subject to an authentication bypass issue in the Operator Console when an external IDP is enabled. All users on release v0.12.2 and before are affected and are advised to update to 0.12.3 or newer. Users unable to upgrade should add automountServiceAccountToken: false to the operator-console deployment in Kubernetes so no service account token will get mounted inside the pod, then disable the external identity provider authentication by unset the CONSOLE_IDP_URL, CONSOLE_IDP_CLIENT_ID, CONSOLE_IDP_SECRET and CONSOLE_IDP_CALLBACK environment variable and instead use the Kubernetes service account token.

  • CVE-2021-41266 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as CRITICAL severity.
  • Affected Vendor/Software: URL Logo minio - console version < 0.12.3

CVSS3 Score: 9.8 - CRITICAL

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.8 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Authentication bypass issue in the Operator Console · Advisory · minio/console · GitHub github.com
text/html
URL Logo CONFIRM github.com/minio/console/security/advisories/GHSA-4999-659w-mq36
Fixed broken oauth2 login for operator by Alevsk · Pull Request #1217 · minio/console · GitHub github.com
text/html
URL Logo MISC github.com/minio/console/pull/1217

Related QID Numbers

  • 980115 Go (go) Security Update for github.com/minio/console (GHSA-4999-659w-mq36)

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationMinMinio ConsoleAllAllAllAll
  • cpe:2.3:a:min:minio_console:*:*:*:*:*:*:*:*:

Social Mentions

Source Title Posted (UTC)
Twitter Icon @CVEreport CVE-2021-41266 : Minio console is a graphical user interface for the for MinIO operator. Minio itself is a multi-cl… twitter.com/i/web/status/1… 2021-11-15 20:24:00
Twitter Icon @SecRiskRptSME RT: CVE-2021-41266 Minio console is a graphical user interface for the for MinIO operator. Minio itself is a multi… twitter.com/i/web/status/1… 2021-11-16 08:33:25
© CVE.report 2021 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report