CVE-2021-41269

Published on: 11/15/2021 12:00:00 AM UTC

Last Modified on: 11/19/2021 04:17:00 PM UTC

CVE-2021-41269 - advisory for GHSA-p9m8-27x8-rg87

Source: Mitre Source: Nist Print: PDF PDF
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Certain versions of Cron-utils from Cron-utils Project contain the following vulnerability:

cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. The issue was patched and a new version was released. Please upgrade to version 9.1.6. There are no known workarounds known.

  • CVE-2021-41269 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as CRITICAL severity.
  • Affected Vendor/Software: URL Logo jmrozanec - cron-utils version < 9.1.6

CVSS3 Score: 9.8 - CRITICAL

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 6.8 - MEDIUM

Access
Vector
Access
Complexity
Authentication
NETWORK MEDIUM NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL PARTIAL

CVE References

Description Tags Link
Merge pull request #494 from NielsDoucet/RCE-fix · jmrozanec/[email protected] · GitHub github.com
text/html
URL Logo MISC github.com/jmrozanec/cron-utils/commit/cfd2880f80e62ea74b92fa83474c2aabdb9899da
Merge pull request #493 from pwntester/patch-1 · jmrozanec/[email protected] · GitHub github.com
text/html
URL Logo MISC github.com/jmrozanec/cron-utils/commit/d6707503ec2f20947f79e38f861dba93b39df9da
Fix security vulnerability regarding the Hibernate dependency. · Issue #461 · jmrozanec/cron-utils · GitHub github.com
text/html
URL Logo MISC github.com/jmrozanec/cron-utils/issues/461
Critical vulnerability found in cron-utils · Advisory · jmrozanec/cron-utils · GitHub github.com
text/html
URL Logo CONFIRM github.com/jmrozanec/cron-utils/security/advisories/GHSA-p9m8-27x8-rg87

Related QID Numbers

  • 980116 Java (maven) Security Update for com.cronutils:cron-utils (GHSA-p9m8-27x8-rg87)

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationCron-utils ProjectCron-utilsAllAllAllAll
  • cpe:2.3:a:cron-utils_project:cron-utils:*:*:*:*:*:*:*:*:

Social Mentions

Source Title Posted (UTC)
Twitter Icon @CVEreport CVE-2021-41269 : cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readab… twitter.com/i/web/status/1… 2021-11-15 20:34:27
Twitter Icon @SecRiskRptSME RT: CVE-2021-41269 cron-utils is a Java library to define, parse, validate, migrate crons as well as get human rea… twitter.com/i/web/status/1… 2021-11-16 08:33:26
© CVE.report 2021 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report