CVE-2022-33683

Published on: Not Yet Published

Last Modified on: 09/27/2022 01:22:00 PM UTC

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Certain versions of Pulsar from Apache contain the following vulnerability:

Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

  • CVE-2022-33683 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as MEDIUM severity.
  • Affected Vendor/Software: URL Logo Apache Software Foundation - Apache Pulsar version <= 2.7.4
  • Affected Vendor/Software: URL Logo Apache Software Foundation - Apache Pulsar version <= 2.8.3
  • Affected Vendor/Software: URL Logo Apache Software Foundation - Apache Pulsar version <= 2.9.2
  • Affected Vendor/Software: URL Logo Apache Software Foundation - Apache Pulsar version = 2.10.0
  • Affected Vendor/Software: URL Logo Apache Software Foundation - Apache Pulsar version <= 2.6.4
Vulnerability Patch/Work Around
  • Any users running affected versions of the Pulsar Broker or Pulsar Proxy should rotate static authentication data vulnerable to man in the middle attacks used by these applications, including tokens and passwords. 2.7 users should upgrade Pulsar Brokers and Proxies to 2.7.5, and rotate vulnerable authentication data, including tokens and passwords. 2.8 users should upgrade Pulsar Brokers and Proxies to 2.8.4, and rotate vulnerable authentication data, including tokens and passwords. 2.9 users should upgrade Pulsar Brokers and Proxies to 2.9.3, and rotate vulnerable authentication data, including tokens and passwords. 2.10 users should upgrade Pulsar Brokers and Proxies to 2.10.1, and rotate vulnerable authentication data, including tokens and passwords. Any users running Pulsar Brokers and Proxies for 2.6 and earlier should upgrade to one of the above patched versions, and rotate vulnerable authentication data, including tokens and passwords. In addition to upgrading, it is also necessary to enable hostname verification to prevent man in the middle attacks. Please see CVE-2022-33682 for more information.

CVSS3 Score: 5.9 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK HIGH NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH NONE NONE

CVE References

Description Tags Link
No Description Provided lists.apache.org
text/html
URL Logo MISC lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationApachePulsarAllAllAllAll
ApplicationApachePulsar2.10.0-AllAll
  • cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:apache:pulsar:2.10.0:-:*:*:*:*:*:*:

Discovery Credit

This issue was discovered by Michael Marshall of DataStax.

Social Mentions

Source Title Posted (UTC)
Twitter Icon @CVEreport CVE-2022-33683 : #Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify pee… twitter.com/i/web/status/1… 2022-09-23 09:27:35
Reddit Logo Icon /r/netcve CVE-2022-33683 2022-09-23 10:38:15
© CVE.report 2022 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report