Published on: Not Yet Published
Last Modified on: 01/23/2023 03:02:00 PM UTC
CVE-2023-22488 - advisory for GHSA-8gcg-vwmw-rxj4Source: Mitre Source: NIST CVE.ORG Print: PDF
Certain versions of Flarum from Flarum contain the following vulnerability:
Flarum is a forum software for building communities. Using the notifications feature, one can read restricted/private content and bypass access checks that would be in place for such content. The notification-sending component does not check that the subject of the notification can be seen by the receiver, and proceeds to send notifications through their different channels. The alerts do not leak data despite this as they are listed based on a visibility check, however, emails are still sent out. This means that, for extensions which restrict access to posts, any actor can bypass the restriction by subscribing to the discussion if the Subscriptions extension is enabled. The attack allows the leaking of some posts in the forum database, including posts awaiting approval, posts in tags the user has no access to if they could subscribe to a discussion before it becomes private, and posts restricted by third-party extensions. All Flarum versions prior to v1.6.3 are affected. The vulnerability has been fixed and published as flarum/core v1.6.3. All communities running Flarum should upgrade as soon as possible to v1.6.3. As a workaround, disable the Flarum Subscriptions extension or disable email notifications altogether. There are no other supported workarounds for this issue for Flarum versions below 1.6.3.
- CVE-2023-22488 has been assigned by [email protected] to track the vulnerability - currently rated as MEDIUM severity.
- Affected Vendor/Software: flarum - framework version = < 1.6.3
CVSS3 Score: 5.4 - MEDIUM
|Merge pull request from GHSA-8gcg-vwmw-rxj4 · flarum/[email protected] · GitHub|| github.com |
|Notifications can leak restricted content · Advisory · flarum/framework · GitHub|| github.com |
Known Affected Configurations (CPE V2.3)