Published on: Not Yet Published
Last Modified on: 02/02/2023 05:54:00 PM UTC
CVE-2023-23613 - advisory for GHSA-v3cg-7r9h-r2g6Source: Mitre Source: NIST CVE.ORG Print: PDF
Certain versions of Opensearch from Amazon contain the following vulnerability:
OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.
- CVE-2023-23613 has been assigned by [email protected] to track the vulnerability - currently rated as MEDIUM severity.
- Affected Vendor/Software: opensearch-project - security version = >= 2.0.0, < 2.5.0
- Affected Vendor/Software: opensearch-project - security version = < 1.3.8
CVSS3 Score: 6.5 - MEDIUM
|Field-level security issue with .keyword fields · Advisory · opensearch-project/security · GitHub|| github.com |
|Release 2.5.0 · opensearch-project/OpenSearch · GitHub|| github.com |
Known Affected Configurations (CPE V2.3)