CVE-2023-27577

Published on: Not Yet Published

Last Modified on: 03/16/2023 03:35:00 PM UTC

CVE-2023-27577 - advisory for GHSA-vhm8-wwrf-3gcw

Source: Mitre Source: NIST CVE.ORG Print: PDF PDF
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Certain versions of Flarum from Flarum contain the following vulnerability:

flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.

  • CVE-2023-27577 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as MEDIUM severity.
  • Affected Vendor/Software: URL Logo flarum - framework version = < 1.7.0

CVSS3 Score: 4.9 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW HIGH NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH NONE NONE

CVE References

Description Tags Link
fix: disallow certain dangerous LESS features · flarum/[email protected] · GitHub github.com
text/html
URL Logo MISC github.com/flarum/framework/commit/1761660c98ea5a3e9665fb8e6041d1f2ee62a444
Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files · Advisory · flarum/framework · GitHub github.com
text/html
URL Logo MISC github.com/flarum/framework/security/advisories/GHSA-vhm8-wwrf-3gcw

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationFlarumFlarumAllAllAllAll
  • cpe:2.3:a:flarum:flarum:*:*:*:*:*:*:*:*:

Social Mentions

Source Title Posted (UTC)
Twitter Icon @CVEreport CVE-2023-27577 : flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin a… twitter.com/i/web/status/1… 2023-03-10 21:30:14
Reddit Logo Icon /r/netcve CVE-2023-27577 2023-03-10 22:38:32
© CVE.report 2023 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report