Published on: Not Yet Published
Last Modified on: 03/21/2023 07:14:00 PM UTC
CVE-2023-27596 - advisory for GHSA-3ghx-j39m-cw4fSource: Mitre Source: NIST CVE.ORG Print: PDF
Certain versions of Opensips from Opensips contain the following vulnerability:
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.
- CVE-2023-27596 has been assigned by [email protected] to track the vulnerability - currently rated as HIGH severity.
- Affected Vendor/Software: OpenSIPS - opensips version = < 3.1.8
- Affected Vendor/Software: OpenSIPS - opensips version = >= 3.2.0, < 3.2.5
CVSS3 Score: 7.5 - HIGH
|[sipmsgops] fix codec_delete_XX() parsing · OpenSIPS/[email protected] · GitHub|| github.com |
|Vulnerability 3 in the codec_delete_XX() functions · Advisory · OpenSIPS/opensips · GitHub|| github.com |
Known Affected Configurations (CPE V2.3)
|@CVEreport||CVE-2023-27596 : OpenSIPS is a Session Initiation Protocol SIP server implementation. Prior to versions 3.1.8 and… twitter.com/i/web/status/1…||2023-03-15 21:06:04|