Server-Side Request Forgery (SSRF) in GitLab
Summary
| CVE | CVE-2026-100104 |
|---|---|
| State | PUBLISHED |
| Assigner | GitLab |
| Source Priority | CVE Program / NVD first with legacy fallback |
| Published | 2026-10-13 02:16:54 UTC |
| Updated | 2026-10-14 20:17:27 UTC |
| Description | GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.3 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to perform server-side request forgery and reach internal network resources due to a time-of-check to time-of-use race condition in URL validation during repository import operations. |
Risk And Classification
Primary CVSS: v3.1 3.5 LOW from [email protected]
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
Problem Types: CWE-918 | CWE-918 CWE-918: Server-Side Request Forgery (SSRF)
| Version | Source | Type | Score | Severity | Vector |
|---|---|---|---|---|---|
| 3.1 | [email protected] | Secondary | 3.5 | LOW | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N |
| 3.1 | CNA | CVSS | 3.5 | LOW | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N |
CVSS v3.1 Breakdown
Attack Vector
NetworkAttack Complexity
HighPrivileges Required
LowUser Interaction
NoneScope
ChangedConfidentiality
LowIntegrity
NoneAvailability
NoneCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
NVD Known Affected Configurations (CPE 2.3)
Vendor Declared Affected Products
References
| Reference | Source | Link | Tags |
|---|---|---|---|
| gitlab.com/gitlab-org/gitlab/-/work_items/594194 | [email protected] | gitlab.com | Issue Tracking |
| docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released | [email protected] | docs.gitlab.com | Release Notes, Vendor Advisory |
| CVE Program record | CVE.ORG | www.cve.org | canonical |
| NVD vulnerability detail | NVD | nvd.nist.gov | canonical, analysis |
Vendor Comments And Credit
Discovery Credit
CNA: This vulnerability has been discovered internally by GitLab team member Félix Veillette-Potvin (en)
Additional Advisory Data
Solutions
CNA: Upgrade to versions 19.2.8, 19.3.5, 19.4.2 or above.
There are currently no legacy QID mappings associated with this CVE.