Acceptance of Extraneous Untrusted Data With Trusted Data in GitLab
Summary
| CVE | CVE-2026-100755 |
|---|---|
| State | PUBLISHED |
| Assigner | GitLab |
| Source Priority | CVE Program / NVD first with legacy fallback |
| Published | 2026-10-13 02:16:55 UTC |
| Updated | 2026-10-14 19:17:00 UTC |
| Description | GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain deployment configurations, could have allowed an authenticated user to poison cached page content served to other users due to improper cache key construction. |
Risk And Classification
Primary CVSS: v3.1 4.6 MEDIUM from [email protected]
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
Problem Types: CWE-349 | CWE-349 CWE-349: Acceptance of Extraneous Untrusted Data With Trusted Data
| Version | Source | Type | Score | Severity | Vector |
|---|---|---|---|---|---|
| 3.1 | [email protected] | Secondary | 4.6 | MEDIUM | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L |
| 3.1 | CNA | CVSS | 4.6 | MEDIUM | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L |
CVSS v3.1 Breakdown
Attack Vector
NetworkAttack Complexity
HighPrivileges Required
LowUser Interaction
RequiredScope
UnchangedConfidentiality
LowIntegrity
LowAvailability
LowCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
NVD Known Affected Configurations (CPE 2.3)
Vendor Declared Affected Products
References
| Reference | Source | Link | Tags |
|---|---|---|---|
| docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released | [email protected] | docs.gitlab.com | Release Notes, Vendor Advisory |
| gitlab.com/gitlab-org/gitlab/-/work_items/627507 | [email protected] | gitlab.com | Issue Tracking |
| CVE Program record | CVE.ORG | www.cve.org | canonical |
| NVD vulnerability detail | NVD | nvd.nist.gov | canonical, analysis |
Vendor Comments And Credit
Discovery Credit
CNA: This vulnerability has been discovered internally by GitLab team member Peter Arts (en)
Additional Advisory Data
Solutions
CNA: Upgrade to versions 19.2.8, 19.3.5, 19.4.2 or above.
There are currently no legacy QID mappings associated with this CVE.