{"api_version":"1","generated_at":"2026-10-29T09:21:14+00:00","cve":"CVE-2024-3586","urls":{"html":"https://cve.report/CVE-2024-3586","api":"https://cve.report/api/cve/CVE-2024-3586.json","docs":"https://cve.report/api","cve_org":"https://www.cve.org/CVERecord?id=CVE-2024-3586","nvd":"https://nvd.nist.gov/vuln/detail/CVE-2024-3586"},"summary":{"title":"LetterPress < 2.4.0 - Admin+ Stored XSS","description":"The LetterPress  WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)","state":"PUBLISHED","assigner":"WPScan","published_at":"2026-10-29 06:17:16","updated_at":"2026-10-29 06:17:16"},"problem_types":["CWE-79 Cross-Site Scripting (XSS)"],"metrics":[],"references":[{"url":"https://wpscan.com/vulnerability/8e3291be-265c-4dec-876c-3e8e3ec0443a/","name":"https://wpscan.com/vulnerability/8e3291be-265c-4dec-876c-3e8e3ec0443a/","refsource":"contact@wpscan.com","tags":[],"title":"","mime":"","httpstatus":"","archivestatus":"0"},{"url":"https://www.cve.org/CVERecord?id=CVE-2024-3586","name":"CVE Program record","refsource":"CVE.ORG","tags":["canonical"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2024-3586","name":"NVD vulnerability detail","refsource":"NVD","tags":["canonical","analysis"]}],"affected":[{"source":"CNA","vendor":"Unknown","product":"LetterPress","version":"affected 2.4.0 semver","platforms":[]}],"timeline":[],"solutions":[],"workarounds":[],"exploits":[],"credits":[{"source":"CNA","value":"SANU P.L","lang":"en"},{"source":"CNA","value":"WPScan","lang":"en"}],"nvd_cpes":[],"vendor_comments":[],"enrichments":{"kev":null,"epss":null,"legacy_qids":[]},"source_records":{"cve_program":{"containers":{"cna":{"affected":[{"defaultStatus":"unaffected","product":"LetterPress","vendor":"Unknown","versions":[{"lessThan":"2.4.0","status":"affected","version":"0","versionType":"semver"}]}],"credits":[{"lang":"en","type":"finder","value":"SANU P.L"},{"lang":"en","type":"coordinator","value":"WPScan"}],"descriptions":[{"lang":"en","value":"The LetterPress  WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)"}],"problemTypes":[{"descriptions":[{"description":"CWE-79 Cross-Site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"dateUpdated":"2026-10-29T06:00:23.500Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","shortName":"WPScan"},"references":[{"tags":["exploit","vdb-entry","technical-description"],"url":"https://wpscan.com/vulnerability/8e3291be-265c-4dec-876c-3e8e3ec0443a/"}],"source":{"discovery":"EXTERNAL"},"title":"LetterPress < 2.4.0 - Admin+ Stored XSS","x_generator":{"engine":"WPScan CVE Generator"}}},"cveMetadata":{"assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","assignerShortName":"WPScan","cveId":"CVE-2024-3586","datePublished":"2026-10-29T06:00:23.500Z","dateReserved":"2024-04-10T14:12:39.458Z","dateUpdated":"2026-10-29T06:00:23.500Z","state":"PUBLISHED"},"dataType":"CVE_RECORD","dataVersion":"5.2"},"nvd":{"publishedDate":"2026-10-29 06:17:16","lastModifiedDate":"2026-10-29 06:17:16","problem_types":["CWE-79 Cross-Site Scripting (XSS)"],"metrics":[],"configurations":[]},"legacy_mitre":{"record":{"CveYear":"2024","CveId":"3586","Ordinal":"1","Title":"LetterPress < 2.4.0 - Admin+ Stored XSS","CVE":"CVE-2024-3586","Year":"2024"},"notes":[{"CveYear":"2024","CveId":"3586","Ordinal":"1","NoteData":"The LetterPress  WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)","Type":"Description","Title":"LetterPress < 2.4.0 - Admin+ Stored XSS"}]}}}