Jetty Cross Site Scripting and Information Disclosure Vulnerabilities
BID:34800
Info
Jetty Cross Site Scripting and Information Disclosure Vulnerabilities
| Bugtraq ID: | 34800 |
| Class: | Input Validation Error |
| CVE: |
CVE-2009-1523 CVE-2009-1524 |
| Remote: | Yes |
| Local: | No |
| Published: | May 04 2009 12:00AM |
| Updated: | Apr 13 2015 09:26PM |
| Credit: | Greg Wilkins and oakim Erdfelt |
| Vulnerable: |
VMWare Vcenter Update Manager 4.1 VMWare Vcenter Update Manager 4.0 VMWare Vcenter Update Manager 1.0 S.u.S.E. openSUSE 11.2 Oracle WebLogic Event Server 2.0 Oracle Complex Event Processing 10.3 Mandriva Linux Mandrake 2009.1 x86_64 Mandriva Linux Mandrake 2009.1 Mandriva Linux Mandrake 2009.0 x86_64 Mandriva Linux Mandrake 2009.0 Jetty Jetty 6.1.16 Jetty Jetty 6.1.7 Jetty Jetty 6.0.2 Jetty Jetty 6.0.1 Jetty Jetty 5.1.15 Jetty Jetty 7.0.0.M2 Jetty Jetty 6.1.6 Jetty Jetty 6.1.5 Jetty Jetty 6.1.4 Jetty Jetty 6.1.3 Jetty Jetty 6.1.2 Jetty Jetty 6.1.1 Jetty Jetty 6.1.0pre3 Jetty Jetty 6.1.0pre2 IBM Sterling File Gateway 2.1 IBM Sterling B2B Integrator 5.1 I2P I2P 0.7.10 I2P I2P 0.7.6 HP Insight Orchestration 6.0 |
| Not Vulnerable: |
Jetty Jetty 6.1.17 I2P I2P 0.7.11 HP Insight Orchestration 6.1 |
Discussion
Jetty Cross Site Scripting and Information Disclosure Vulnerabilities
Jetty is prone to a cross-site scripting vulnerability and an information-disclosure vulnerability.
An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, steal cookie-based authentication credentials, and obtain sensitive information.
Jetty 6.1.16 and prior versions are affected.
Jetty is prone to a cross-site scripting vulnerability and an information-disclosure vulnerability.
An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, steal cookie-based authentication credentials, and obtain sensitive information.
Jetty 6.1.16 and prior versions are affected.
Exploit / POC
Jetty Cross Site Scripting and Information Disclosure Vulnerabilities
Attackers can use a browser to exploit these issues. To exploit a cross-site scripting vulnerability, an attacker must entice an unsuspecting victim to follow a malicious URI.
Attackers can use a browser to exploit these issues. To exploit a cross-site scripting vulnerability, an attacker must entice an unsuspecting victim to follow a malicious URI.
Solution / Fix
Jetty Cross Site Scripting and Information Disclosure Vulnerabilities
Solution:
Updates are available. Please see the references for more information.
VMWare Vcenter Update Manager 4.0
Mandriva Linux Mandrake 2009.1 x86_64
Mandriva Linux Mandrake 2009.0
VMWare Vcenter Update Manager 4.1
Mandriva Linux Mandrake 2009.0 x86_64
Mandriva Linux Mandrake 2009.1
VMWare Vcenter Update Manager 1.0
Solution:
Updates are available. Please see the references for more information.
VMWare Vcenter Update Manager 4.0
-
VMWare VUM-KB-1023962.exe
http://www.vmware.com/downloads/download.do?downloadGroup=VUMKB1023962
Mandriva Linux Mandrake 2009.1 x86_64
-
Mandriva jetty5-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-demo-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-javadoc-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-manual-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/
Mandriva Linux Mandrake 2009.0
-
Mandriva jetty5-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-demo-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-javadoc-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-manual-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/
VMWare Vcenter Update Manager 4.1
-
VMWare VUM-KB-1023962.exe
http://www.vmware.com/downloads/download.do?downloadGroup=VUMKB1023962
Mandriva Linux Mandrake 2009.0 x86_64
-
Mandriva jetty5-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-demo-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-javadoc-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-manual-5.1.15-0.1.5.1.1mdv2009.0.noarch.rpm
http://www.mandriva.com/en/download/
Mandriva Linux Mandrake 2009.1
-
Mandriva jetty5-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-demo-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-javadoc-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/ -
Mandriva jetty5-manual-5.1.15-0.1.5.1.1mdv2009.1.noarch.rpm
http://www.mandriva.com/en/download/
VMWare Vcenter Update Manager 1.0
-
VMWare VUM-KB-1023962.exe
http://www.vmware.com/downloads/download.do?downloadGroup=VUMKB1023962
References
Jetty Cross Site Scripting and Information Disclosure Vulnerabilities
References:
References:
- Upgrade the Jetty Web server embedded in VMware vCenter Update Manager by using (VMware)
- 0.7.11 Release (I2P)
- Jetty Homepage (Jetty)
- Jetty HTTP server directory traversal vulnerability (US-CERT)
- Security / Directory Listing XSS present (Codehaus)
- Vulnerability in ResourceHandler and DefaultServlet with aliases (Codehaus)
- Oracle Critical Patch Update Advisory - July 2009 (Oracle)
- Vulnerabilities found in IBM Sterling B2B Integrator and IBM Sterling File Gatew (IBM)