Adobe Flash Player CVE-2011-0574 Remote Memory Corruption Vulnerability
BID:46193
Info
Adobe Flash Player CVE-2011-0574 Remote Memory Corruption Vulnerability
| Bugtraq ID: | 46193 |
| Class: | Unknown |
| CVE: |
CVE-2011-0574 |
| Remote: | Yes |
| Local: | No |
| Published: | Feb 08 2011 12:00AM |
| Updated: | Jun 20 2013 09:40AM |
| Credit: | Bo Qu of Palo Alto Networks |
| Vulnerable: |
SuSE Suse Linux Enterprise Desktop 11 SP1 SuSE Suse Linux Enterprise Desktop 10 SP3 Sun Solaris 10_x86 Sun Solaris 10_sparc S.u.S.E. openSUSE 11.3 S.u.S.E. openSUSE 11.2 Redhat Enterprise Linux WS Extras 4 Redhat Enterprise Linux Workstation Supplementary 6 Redhat Enterprise Linux Supplementary 5.6.Z server Redhat Enterprise Linux Server Supplementary 6 Redhat Enterprise Linux Extras 4 Redhat Enterprise Linux ES Extras 4 Redhat Enterprise Linux Desktop Supplementary 6 Redhat Enterprise Linux AS Extras 4 Redhat Desktop Extras 4 Gentoo Linux Adobe Flash Player 10.1.53 .64 Adobe Flash Player 10.1.51 .66 Adobe Flash Player 10.0.45 2 Adobe Flash Player 10.0.45 2 Adobe Flash Player 10.0.45 2 Adobe Flash Player 10.0.32 18 Adobe Flash Player 10.0.22 .87 Adobe Flash Player 10.0.15 .3 Adobe Flash Player 10.0.12 .36 Adobe Flash Player 10.0.12 .35 Adobe Flash Player 10.1.95.2 Adobe Flash Player 10.1.95.1 Adobe Flash Player 10.1.92.10 Adobe Flash Player 10.1.92.10 Adobe Flash Player 10.1.85.3 Adobe Flash Player 10.1.82.76 Adobe Flash Player 10.1.106.16 Adobe Flash Player 10.1.105.6 Adobe Flash Player 10.1.102.65 Adobe Flash Player 10.1.102.64 Adobe Flash Player 10.1 Release Candida Adobe Flash Player 10.0.42.34 Adobe Flash Player 10.0.32.18 Adobe Flash Player 10 |
| Not Vulnerable: |
Adobe Flash Player 10.2.152.21 |
Discussion
Adobe Flash Player CVE-2011-0574 Remote Memory Corruption Vulnerability
Adobe Flash Player is prone to a remote memory-corruption vulnerability.
An attacker can exploit this issue to execute arbitrary code in the context of the user running the affected application. Failed exploit attempts will likely result in denial-of-service conditions.
Flash Player versions prior to 10.2.152.21 are affected.
Adobe Flash Player is prone to a remote memory-corruption vulnerability.
An attacker can exploit this issue to execute arbitrary code in the context of the user running the affected application. Failed exploit attempts will likely result in denial-of-service conditions.
Flash Player versions prior to 10.2.152.21 are affected.
Exploit / POC
Adobe Flash Player CVE-2011-0574 Remote Memory Corruption Vulnerability
Currently we are not aware of any exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: [email protected].
Currently we are not aware of any exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: [email protected].
Solution / Fix
Adobe Flash Player CVE-2011-0574 Remote Memory Corruption Vulnerability
Solution:
Updates are available. Please see the references for more information.
SuSE openSUSE 11.3
S.u.S.E. openSUSE 11.2
Solution:
Updates are available. Please see the references for more information.
SuSE openSUSE 11.3
-
SuSE acroread-9.4.2-0.2.1.i586.rpm
http://download.opensuse.org/update/11.3/rpm/i586/acroread-9.4.2-0.2.1 .i586.rpm -
SuSE flash-player-10.2.152.26-0.2.1.i586.rpm
http://download.opensuse.org/update/11.3/rpm/i586/flash-player-10.2.15 2.26-0.2.1.i586.rpm
S.u.S.E. openSUSE 11.2
-
SuSE acroread-9.4.2-0.2.1.i586.rpm
http://download.opensuse.org/update/11.3/rpm/i586/acroread-9.4.2-0.2.1 .i586.rpm -
SuSE acroread-cmaps-9.4.2-0.2.1.noarch.rpm
http://download.opensuse.org/update/11.2/rpm/noarch/acroread-cmaps-9.4 .2-0.2.1.noarch.rpm -
SuSE acroread-fonts-ja-9.4.2-0.2.1.noarch.rpm
http://download.opensuse.org/update/11.2/rpm/noarch/acroread-fonts-ja- 9.4.2-0.2.1.noarch.rpm -
SuSE acroread-fonts-ko-9.4.2-0.2.1.noarch.rpm
http://download.opensuse.org/update/11.2/rpm/noarch/acroread-fonts-ko- 9.4.2-0.2.1.noarch.rpm -
SuSE acroread-fonts-zh_CN-9.4.2-0.2.1.noarch.rpm
http://download.opensuse.org/update/11.2/rpm/noarch/acroread-fonts-zh_ CN-9.4.2-0.2.1.noarch.rpm -
SuSE acroread-fonts-zh_TW-9.4.2-0.2.1.noarch.rpm
http://download.opensuse.org/update/11.2/rpm/noarch/acroread-fonts-zh_ TW-9.4.2-0.2.1.noarch.rpm -
SuSE flash-player-10.2.152.26-0.2.1.i586.rpm
http://download.opensuse.org/update/11.3/rpm/i586/flash-player-10.2.15 2.26-0.2.1.i586.rpm
References
Adobe Flash Player CVE-2011-0574 Remote Memory Corruption Vulnerability
References:
References: