Adobe Acrobat and Reader CVE-2011-0567 Image Parsing Remote Memory Corruption Vulnerability
BID:46199
Info
Adobe Acrobat and Reader CVE-2011-0567 Image Parsing Remote Memory Corruption Vulnerability
| Bugtraq ID: | 46199 |
| Class: | Boundary Condition Error |
| CVE: |
CVE-2011-0567 |
| Remote: | Yes |
| Local: | No |
| Published: | Feb 08 2011 12:00AM |
| Updated: | Mar 19 2015 08:21AM |
| Credit: | Abdullah Ada |
| Vulnerable: |
SuSE Suse Linux Enterprise Desktop 11 SP1 SuSE Suse Linux Enterprise Desktop 10 SP3 S.u.S.E. openSUSE 11.3 S.u.S.E. openSUSE 11.2 Redhat Enterprise Linux WS Extras 4 Redhat Enterprise Linux Workstation Supplementary 6 Redhat Enterprise Linux Supplementary 5 server Redhat Enterprise Linux Server Supplementary 6 Redhat Enterprise Linux Extras 4 Redhat Enterprise Linux ES Extras 4 Redhat Enterprise Linux Desktop Supplementary 6 Redhat Enterprise Linux Desktop Supplementary 5 client Redhat Enterprise Linux AS Extras 4 Redhat Desktop Extras 4 Gentoo Linux Adobe Reader 9.3.4 Adobe Reader 9.3.3 Adobe Reader 9.3.2 Adobe Reader 9.3.1 Adobe Reader 9.1.3 Adobe Reader 9.1.2 Adobe Reader 9.1.1 Adobe Reader 8.2.5 Adobe Reader 8.2.4 Adobe Reader 8.2.3 Adobe Reader 8.2.2 Adobe Reader 8.2.1 Adobe Reader 8.1.7 Adobe Reader 8.1.6 Adobe Reader 8.1.5 Adobe Reader 8.1.4 Adobe Reader 8.1.3 Adobe Reader 8.1.2 Adobe Reader 8.1.1 Adobe Reader 9.4.1 Adobe Reader 9.4 Adobe Reader 9.3 Adobe Reader 9.2 Adobe Reader 9.1 Adobe Reader 9.0 Adobe Reader 8.2 Adobe Reader 8.1.2 Security Updat Adobe Reader 8.1 Adobe Reader 8.0 Adobe Reader 10.0 Adobe Acrobat Standard 9.3.4 Adobe Acrobat Standard 9.3.3 Adobe Acrobat Standard 9.3.2 Adobe Acrobat Standard 9.3.1 Adobe Acrobat Standard 9.1.3 Adobe Acrobat Standard 9.1.2 Adobe Acrobat Standard 8.2.5 Adobe Acrobat Standard 8.2.4 Adobe Acrobat Standard 8.2.2 Adobe Acrobat Standard 8.2.1 Adobe Acrobat Standard 8.1.7 Adobe Acrobat Standard 8.1.6 Adobe Acrobat Standard 8.1.4 Adobe Acrobat Standard 8.1.3 Adobe Acrobat Standard 8.1.2 Adobe Acrobat Standard 8.1.1 Adobe Acrobat Standard 9.4.1 Adobe Acrobat Standard 9.4 Adobe Acrobat Standard 9.3 Adobe Acrobat Standard 9.2 Adobe Acrobat Standard 9.1 Adobe Acrobat Standard 9 Adobe Acrobat Standard 8.2 Adobe Acrobat Standard 8.1 Adobe Acrobat Standard 8.0 Adobe Acrobat Standard 10.0 Adobe Acrobat Professional 9.3.4 Adobe Acrobat Professional 9.3.3 Adobe Acrobat Professional 9.3.2 Adobe Acrobat Professional 9.3.1 Adobe Acrobat Professional 9.1.3 Adobe Acrobat Professional 9.1.2 Adobe Acrobat Professional 8.2.5 Adobe Acrobat Professional 8.2.4 Adobe Acrobat Professional 8.2.2 Adobe Acrobat Professional 8.2.1 Adobe Acrobat Professional 8.1.7 Adobe Acrobat Professional 8.1.6 Adobe Acrobat Professional 8.1.4 Adobe Acrobat Professional 8.1.3 Adobe Acrobat Professional 8.1.2 Adobe Acrobat Professional 8.1.1 Adobe Acrobat Professional 9.4.1 Adobe Acrobat Professional 9.4 Adobe Acrobat Professional 9.3 Adobe Acrobat Professional 9.2 Adobe Acrobat Professional 9.1 Adobe Acrobat Professional 9 Extended Adobe Acrobat Professional 9 Adobe Acrobat Professional 8.2 Adobe Acrobat Professional 8.1.2 Security Updat Adobe Acrobat Professional 8.1 Adobe Acrobat Professional 8.0 Adobe Acrobat Professional 10.0 Adobe Acrobat 9.3.3 Adobe Acrobat 9.3.2 Adobe Acrobat 9.3.1 Adobe Acrobat 9.1.1 Adobe Acrobat 8.2.5 Adobe Acrobat 8.2.4 Adobe Acrobat 8.2.4 Adobe Acrobat 8.2.3 Adobe Acrobat 8.2.2 Adobe Acrobat 8.1.8 Adobe Acrobat 9.4.1 Adobe Acrobat 9.4 Adobe Acrobat 9.3 Adobe Acrobat 9.2 Adobe Acrobat 10.0 |
| Not Vulnerable: |
Adobe Reader 9.4.2 Adobe Reader 10.0.1 Adobe Acrobat Standard 9.4.2 Adobe Acrobat Standard 10.0.1 Adobe Acrobat Professional 9.4.2 Adobe Acrobat Professional 10.0.1 Adobe Acrobat 9.4.2 Adobe Acrobat 10.0.1 |
Discussion
Adobe Acrobat and Reader CVE-2011-0567 Image Parsing Remote Memory Corruption Vulnerability
Adobe Acrobat and Reader are prone to a remote memory-corruption vulnerability.
Attackers can exploit this issue to execute arbitrary code in the context of the user running the affected application.
Adobe Reader and Acrobat versions prior to 9.4.2 and 10.0.1 are affected.
Adobe Acrobat and Reader are prone to a remote memory-corruption vulnerability.
Attackers can exploit this issue to execute arbitrary code in the context of the user running the affected application.
Adobe Reader and Acrobat versions prior to 9.4.2 and 10.0.1 are affected.
Exploit / POC
Adobe Acrobat and Reader CVE-2011-0567 Image Parsing Remote Memory Corruption Vulnerability
Currently we are not aware of any exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: [email protected].
Currently we are not aware of any exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: [email protected].
Solution / Fix
Adobe Acrobat and Reader CVE-2011-0567 Image Parsing Remote Memory Corruption Vulnerability
Solution:
Updates are available. Please see the references for more information.
S.u.S.E. openSUSE 11.3
Solution:
Updates are available. Please see the references for more information.
S.u.S.E. openSUSE 11.3
-
SuSE acroread-9.4.2-0.2.1.i586.rpm
http://download.opensuse.org/update/11.3/rpm/i586/acroread-9.4.2-0.2.1 .i586.rpm
References
Adobe Acrobat and Reader CVE-2011-0567 Image Parsing Remote Memory Corruption Vulnerability
References:
References:
- Adobe Homepage (Adobe)
- APSB11-03 Security updates available for Adobe Reader and Acrobat (Adobe)
- ZDI-11-065 Adobe Reader Controlled memset Remote Code Execution Vulnerability (Zero Day Initiative)