QID 239368

Date Published: 2021-06-09

QID 239368: Red Hat Update for rh-ruby26-ruby (RHSA-2021:2230)

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. The following packages have been upgraded to a later upstream version: rh-ruby26-ruby (2.6.7). (BZ#1701182)

Security Fix(es): rubygem-bundler: Insecure permissions on directory in /tmp/ allows for execution of malicious code (CVE-2019-3881) ruby: NUL injection vulnerability of File.fnmatch and File.fnmatch? (CVE-2019-15845) ruby: Regular expression denial of service vulnerability of WEBrick's Digest authentication (CVE-2019-16201) ruby: Code injection via command argument of Shell#test / Shell#[] (CVE-2019-16255) rubygem-json: Unsafe object creation vulnerability in JSON (CVE-2020-10663) ruby: BasicSocket#read_nonblock method leads to information disclosure (CVE-2020-10933) ruby: Potential HTTP request smuggling in WEBrick (CVE-2020-25613) ruby: XML round-trip vulnerability in REXML (CVE-2021-28965) ruby: HTTP response splitting in WEBrick (CVE-2019-16254)

Affected Products:

Red Hat Software Collections (for RHEL Server) 1 for RHEL 7.7 x86_64
Red Hat Software Collections (for RHEL Server for System Z) 1 for RHEL 7.7 s390x
Red Hat Software Collections (for RHEL Server for IBM Power LE) 1 for RHEL 7.7 ppc64le
Red Hat Software Collections (for RHEL Server) 1 for RHEL 7 x86_64
Red Hat Software Collections (for RHEL Server for System Z) 1 for RHEL 7 s390x
Red Hat Software Collections (for RHEL Server for IBM Power LE) 1 for RHEL 7 ppc64le
Red Hat Software Collections (for RHEL Workstation) 1 for RHEL 7 x86_64

Note: The preceding description block is extracted directly from the security advisory. Using automation, we have attempted to clean and format it as much as possible without introducing additional issues.

On successful exploitation, it could allow an attacker to execute code.

  • CVSS V3 rated as Critical - 8.1 severity.
  • CVSS V2 rated as High - 6.8 severity.
  • Solution
    Upgrade to the latest packages which contain a patch. Refer to Applying Package Updates to RHEL system for details.

    Refer to Red Hat security advisory RHSA-2021:2230 to address this issue and obtain more information.

    Vendor References
    Software Advisories
    Advisory ID Software Component Link
    RHSA-2021:2230 Red Hat Enterprise Linux URL Logo access.redhat.com/errata/RHSA-2021:2230?language=en