QID 239645

Date Published: 2021-09-24

QID 239645: Red Hat Update for nodejs:12 (RHSA-2021:3623)

Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language.

Security Fix(es): nodejs: Use-after-free on close http2 on stream canceling (CVE-2021-22930) nodejs: Use-after-free on close http2 on stream canceling (CVE-2021-22940) c-ares: Missing input validation of host names may lead to domain hijacking (CVE-2021-3672) nodejs: Improper handling of untypical characters in domain names (CVE-2021-22931) nodejs-tar: Insufficient symlink protection allowing arbitrary file creation and overwrite (CVE-2021-32803) nodejs-tar: Insufficient absolute path sanitization allowing arbitrary file creation and overwrite (CVE-2021-32804) nodejs: Incomplete validation of tls rejectUnauthorized parameter (CVE-2021-22939) nodejs-path-parse: ReDoS via splitDeviceRe, splitTailRe and splitPathRe (CVE-2021-23343)

Affected Products:

Red Hat Enterprise Linux for x86_64 8 x86_64
Red Hat Enterprise Linux for x86_64 - Extended Update Support 8.4 x86_64
Red Hat Enterprise Linux Server - AUS 8.4 x86_64
Red Hat Enterprise Linux for IBM z Systems 8 s390x
Red Hat Enterprise Linux for IBM z Systems - Extended Update Support 8.4 s390x
Red Hat Enterprise Linux for Power, little endian 8 ppc64le
Red Hat Enterprise Linux for Power, little endian - Extended Update Support 8.4 ppc64le
Red Hat Enterprise Linux Server - TUS 8.4 x86_64
Red Hat Enterprise Linux for ARM 64 8 aarch64
Red Hat Enterprise Linux for ARM 64 - Extended Update Support 8.4 aarch64
Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions 8.4 ppc64le
Red Hat Enterprise Linux Server - Update Services for SAP Solutions 8.4 x86_64

Note: The preceding description block is extracted directly from the security advisory. Using automation, we have attempted to clean and format it as much as possible without introducing additional issues.

On successful exploitation, it could allow an attacker to execute code.

  • CVSS V3 rated as Critical - 9.8 severity.
  • CVSS V2 rated as High - 7.5 severity.
  • Solution
    Upgrade to the latest packages which contain a patch. Refer to Applying Package Updates to RHEL system for details.

    Refer to Red Hat security advisory RHSA-2021:3623 to address this issue and obtain more information.

    Vendor References
    Software Advisories
    Advisory ID Software Component Link
    RHSA-2021:3623 Red Hat Enterprise Linux URL Logo access.redhat.com/errata/RHSA-2021:3623?language=en