QID 376157

Date Published: 2021-12-11

QID 376157: Apache Log4j Remote Code Execution (RCE) Vulnerability (Log4Shell)

A zero-day exploit affecting the popular Apache Log4j utility (CVE-2021-44228) was made public on December 9, 2021 that results in remote code execution (RCE).

Affected versions:
Log4j versions 2.x prior to and including 2.14.1 (exclude 2.12.x)
Log4j versions 2.12.x prior to 2.12.2

QID Detection: (Authenticated) - Linux
This detection is based on querying the OS package managers on the target. If the target has a log4j package with a version less than 2.15.0, the target is flagged as vulnerable. This detection logic is updated to find log4j installs using the locate command and ls proc command. These updates are in VULNSIGS-2.5.352-4
QID Detection: (Authenticated) - Windows
On Windows system, the QID identifies vulnerable instance of log4j via WMI to check log4j included in the running processes via command-line.

Note:QID 376157 leverages the OS package manager to identify vulnerable Log4j packages. If the target does not have the vulnerable log4j package installed via the package manager, this QID might not get detected. This would typically happen when an application bundles the Log4j library in a jar etc.

Successful exploitation of this vulnerability could lead to remote code execution (RCE) on the target.

  • CVSS V3 rated as Critical - 10 severity.
  • CVSS V2 rated as Critical - 9.3 severity.
  • Solution
    The vendor has released a fix for this vulnerability and the customers are advised to update their Log4j to the version 2.15.0. If updating the version is not possible, please refer to the mitigations mentioned here Log4j.
    Vendor References

    CVEs related to QID 376157

    Software Advisories
    Advisory ID Software Component Link
    Apache Log4j URL Logo logging.apache.org/log4j/2.x/download.html