QID 376194

Date Published: 2021-12-19

QID 376194: Apache Log4j Denial of Service (DOS) Vulnerability (Log4Shell)

Apache Log4j2 does not always protect from infinite recursion in lookup evaluation (CVE-2021-45105), this was made public on December 18, 2021

Affected versions:
Log4j versions all versions from 2.0-beta9 to 2.16.0, excluding 2.12.3, 2.3.1

QID Detection: (Authenticated)
This detection is based on querying the OS package managers on the target. If the target has a log4j package with a version less than or equals to 2.16.0, the target is flagged as vulnerable. This detection logic also tries to find log4j installs using the locate command and ls proc command. These updates are in VULNSIGS-2_5_357
QID Detection: (Authenticated) - Windows
On Windows system, the QID identifies vulnerable instance of log4j via WMI to check log4j included in the running processes via command-line.

Apache Log4j2 versions 2.0-alpha1 through 2.16.0, excluding 2.12.3, 2.3.1 did not protect from uncontrolled recursion from self-referential lookups. When the logging configuration uses a non-default Pattern Layout with a Context Lookup (for example, $${ctx:loginId}), attackers with control over Thread Context Map (MDC) input data can craft malicious input data that contains a recursive lookup, resulting in a StackOverflowError that will terminate the process. This is also known as a DOS (Denial of Service) attack.

  • CVSS V3 rated as Medium - 5.9 severity.
  • CVSS V2 rated as Medium - 4.3 severity.
  • Solution
    Apache recommends customers to upgrade to Log4j 2.3.1 (for Java 6), 2.12.3 (for Java 7), or 2.17.0 (for Java 8 and later). If updating the version is not possible, please refer to the mitigations mentioned here Log4j.
    Vendor References

    CVEs related to QID 376194

    Software Advisories
    Advisory ID Software Component Link
    Apache Log4j URL Logo logging.apache.org/log4j/2.x/download.html