QID 376195

Date Published: 2021-12-19

QID 376195: Apache Log4j Denial of Service (DOS) Vulnerability (Log4Shell) Detected Based on Qualys Log4j scan Utility

Apache Log4j2 does not always protect from infinite recursion in lookup evaluation (CVE-2021-45105), this was made public on December 18, 2021

Affected versions:
Log4j versions 2.x prior to and including 2.16

QID Detection: (Authenticated)
Operating System: Windows
This QID reads the file generated by Qualys utility Qualys Log4j Scan Utility for Windows
The QID reads 1st 100000 characters from the generated out put file.

QID Detection: (Authenticated)
Operating System: Linux
This QID reads the file generated by Qualys utility Qualys Log4j Scan Utility for Linux to find vulnerable instances of Log4j.

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 did not protect from uncontrolled recursion from self-referential lookups. When the logging configuration uses a non-default Pattern Layout with a Context Lookup (for example, $${ctx:loginId}), attackers with control over Thread Context Map (MDC) input data can craft malicious input data that contains a recursive lookup, resulting in a StackOverflowError that will terminate the process. This is also known as a DOS (Denial of Service) attack.

  • CVSS V3 rated as Medium - 5.9 severity.
  • CVSS V2 rated as Medium - 4.3 severity.
  • Solution
    Apache recommends customers to upgrade to Log4j 2.3.1 (for Java 6), 2.12.3 (for Java 7), or 2.17.0 (for Java 8 and later). If updating the version is not possible, please refer to the mitigations mentioned here Log4j.
    Vendor References

    CVEs related to QID 376195

    Software Advisories
    Advisory ID Software Component Link
    NA URL Logo logging.apache.org/log4j/2.x/download.html