QID 590580

Date Published: 2021-12-23

QID 590580: Siemens SINUMERIK Heap-based Buffer Overflow Vulnerability (ICSA-21-287-04)

AFFECTED PRODUCTS
The following versions of SINUMERIK controllers are affected:
SINUMERIK 808D: All versions
SINUMERIK 828D: All versions prior to v4.95

QID Detection Logic (Authenticated):
QID checks for the Vulnerable version of using passive scanning

Successful exploitation of this vulnerability could allow an unauthenticated attacker, with network access to the affected devices, to cause system failure with total loss of availability.

  • CVSS V3 rated as High - 7.5 severity.
  • CVSS V2 rated as High - 7.8 severity.
  • Solution

    Customers are advised to refer to CERT MITIGATIONS section ICSA-21-287-04 for affected packages and patching details.

    Vendor References

    CVEs related to QID 590580

    Software Advisories
    Advisory ID Software Component Link
    ICSA-21-287-04 URL Logo www.us-cert.gov/ics/advisories/ICSA-21-287-04