QID 730302

Date Published: 2021-12-17

QID 730302: Atlassian Bitbucket Server and Data Center Versions Security Fixes (CVE-2021-44228)

Bitbucket Server Data Center are vulnerable to CVE 2021 44228 via bundled prerequisite software Elasticsearch as no updated versions for Elasticsearch is feasible hence updated versions of Bitbucket are released

Affected Bitbucket Data Center Versions

All version prior to 6.10.16
All version prior to 7.6.12
Version from 7.7.0 prior to 7.14.2
Version from 7.15.x prior to 7.15.3
Version from 7.16.x prior to 7.16.3
Version from 7.17.x prior to 7.17.4
Version from 7.18.x prior to 7.18.3
Version 7.19

Fixed Bitbucket Server Data Center Versions
6.10.16
7.6.12
7.14.2
7.15.3
7.16.3
7.17.4
7.18.3
7.19.1
Detection Logic:

QID checks for the vulnerable versions of Bitbucket Server via GET login request.

Successful exploitation of this vulnerability could lead to information leakage

  • CVSS V3 rated as Critical - 10 severity.
  • CVSS V2 rated as Critical - 9.3 severity.
  • Solution
    Vendor has released fix to this issue. Refer to Bitbucket Server Data Center Download

    CVEs related to QID 730302

    Software Advisories
    Advisory ID Software Component Link
    cve-2021-44228-1103069934 URL Logo confluence.atlassian.com/security/multiple-products-security-advisory-log4j-vulnerable-to-remote-code-execution-cve-2021-44228-1103069934.html