QID 982915

QID 982915: Java (maven) Security Update for org.elasticsearch:elasticsearch (GHSA-hqqv-9x3v-mp7w)

The fix for CVE-2020-7009 was found to be incomplete. Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys and also authentication tokens. An attacker who is able to generate an API key and an authentication token can perform a series of steps that result in an authentication token being generated with elevated privileges.

Successful exploitation of this vulnerability may affect the confidentiality, integrity, and availability of the targeted user.

  • CVSS V3 rated as Critical - 8.8 severity.
  • CVSS V2 rated as High - 6.5 severity.
  • Solution
    Customers are advised to refer to GHSA-hqqv-9x3v-mp7w for updates pertaining to this vulnerability.
    Vendor References

    CVEs related to QID 982915

    Software Advisories
    Advisory ID Software Component Link
    GHSA-hqqv-9x3v-mp7w org.elasticsearch:elasticsearch URL Logo github.com/advisories/GHSA-hqqv-9x3v-mp7w