CVE-2016-2231

Published on: 02/14/2016 12:00:00 AM UTC

Last Modified on: 03/23/2021 11:27:16 PM UTC

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Certain versions of Mt882 from Huawei contain the following vulnerability:

The Windows-based Host Interface Program (WHIP) service on Huawei SmartAX MT882 devices V200R002B022 Arg relies on the client to send a length field that is consistent with a buffer size, which allows remote attackers to cause a denial of service (device outage) or possibly have unspecified other impact via crafted traffic on TCP port 8701.

  • CVE-2016-2231 has been assigned by [email protected] to track the vulnerability - currently rated as - currently rated as CRITICAL severity.

CVSS3 Score: 9.8 - CRITICAL

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK LOW NONE NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED HIGH HIGH HIGH

CVSS2 Score: 9 - HIGH

Access
Vector
Access
Complexity
Authentication
NETWORK LOW NONE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
PARTIAL PARTIAL COMPLETE

CVE References

Description Tags Link
Security Advisory: WHIP Vulnerability | Debi Higa Exploit
debihiga.wordpress.com
text/html
URL Logo MISC debihiga.wordpress.com/sa-whip/

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
HardwareHuaweiMt882-AllAllAll
HardwareHuaweiMt882-AllAllAll
Operating
System
HuaweiMt882 FirmwareAllAllAllAll
  • cpe:2.3:h:huawei:mt882:-:*:*:*:*:*:*:*:
  • cpe:2.3:h:huawei:mt882:-:*:*:*:*:*:*:*:
  • cpe:2.3:o:huawei:mt882_firmware:*:*:*:*:*:*:*:*: