CVE-2022-21451

Published on: Not Yet Published

Last Modified on: 09/21/2022 07:57:00 PM UTC

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H

Certain versions of Mariadb from Mariadb contain the following vulnerability:

Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.37 and prior and 8.0.28 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).

  • CVE-2022-21451 has been assigned by URL Logo [email protected] to track the vulnerability - currently rated as MEDIUM severity.
  • Affected Vendor/Software: URL Logo Oracle Corporation - MySQL Server version = 5.7.37 and prior
  • Affected Vendor/Software: URL Logo Oracle Corporation - MySQL Server version = 8.0.28 and prior

CVSS3 Score: 4.4 - MEDIUM

Attack
Vector
Attack
Complexity
Privileges
Required
User
Interaction
NETWORK HIGH HIGH NONE
Scope Confidentiality
Impact
Integrity
Impact
Availability
Impact
UNCHANGED NONE NONE HIGH

CVSS2 Score: 2.1 - LOW

Access
Vector
Access
Complexity
Authentication
NETWORK HIGH SINGLE
Confidentiality
Impact
Integrity
Impact
Availability
Impact
NONE NONE PARTIAL

CVE References

Description Tags Link
Oracle Critical Patch Update Advisory - April 2022 www.oracle.com
text/html
URL Logo MISC www.oracle.com/security-alerts/cpuapr2022.html
April 2022 MySQL Server Vulnerabilities in NetApp Products | NetApp Product Security security.netapp.com
text/html
URL Logo CONFIRM security.netapp.com/advisory/ntap-20220429-0005/

Related QID Numbers

  • 160112 Oracle Enterprise Linux Security Update for mysql (ELSA-2022-6590)
  • 160186 Oracle Enterprise Linux Security Update for mysql:8.0 (ELSA-2022-7119)
  • 198764 Ubuntu Security Notification for MySQL Vulnerabilities (USN-5400-1)
  • 20256 Oracle MySQL April 2022 Critical Patch Update (CPUAPR2022)
  • 240666 Red Hat Update for rh-mysql80-mysql security (RHSA-2022:6518)
  • 240679 Red Hat Update for mysql security (RHSA-2022:6590)
  • 240780 Red Hat Update for mysql:8.0 security (RHSA-2022:7119)
  • 296082 Oracle Solaris 11.4 Support Repository Update (SRU) 48.126.1 Missing (CPUJUL2022)
  • 377393 Alibaba Cloud Linux Security Update for mariadb:10.5 (ALINUX3-SA-2022:0034)
  • 901457 Common Base Linux Mariner (CBL-Mariner) Security Update for mysql (9551)
  • 902394 Common Base Linux Mariner (CBL-Mariner) Security Update for mysql (9551-1)
  • 940693 AlmaLinux Security Update for mysql (ALSA-2022:6590)
  • 940710 AlmaLinux Security Update for mysql:8.0 (ALSA-2022:7119)
  • 960353 Rocky Linux Security Update for mariadb:10.5 (RLSA-2022:1557)
  • 960427 Rocky Linux Security Update for mariadb:10.3 (RLSA-2022:1556)
  • 960476 Rocky Linux Security Update for mysql (RLSA-2022:6590)

Known Affected Configurations (CPE V2.3)

Type Vendor Product Version Update Edition Language
ApplicationMariadbMariadbAllAllAllAll
ApplicationNetappActive Iq Unified Manager-AllAllAll
ApplicationNetappActive Iq Unified Manager-AllAllAll
ApplicationNetappOncommand Insight-AllAllAll
ApplicationNetappOncommand Workflow Automation-AllAllAll
ApplicationNetappSnapcenter-AllAllAll
ApplicationOracleMysqlAllAllAllAll
ApplicationOracleMysqlAllAllAllAll
  • cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:*:
  • cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:*:
  • cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:*:
  • cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:*:
  • cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:*:
  • cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:*:
  • cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:*:

Social Mentions

Source Title Posted (UTC)
© CVE.report 2023 Twitter Nitter Twitter Viewer |

Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.

CVE, CWE, and OVAL are registred trademarks of The MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. This site includes MITRE data granted under the following license.

CVE.report and Source URL Uptime Status status.cve.report